Для удобного просмотра сайта рекомендуется использовать Google Chrome.


Закрытая тема
Показано с 1 по 9 из 9

Тема: Примитивные типы

  1. #1
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию Примитивные типы

    Null

    Null
    Описание:
    Значения данного типа используются исключительно для определения отсутствующего значения при работе с базой данных, например, при соединении таблиц.
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Значение NULL представляется в XDTO в виде пустой строки.

  2. #2
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Неопределено (Undefined)

    Неопределено (Undefined)
    Описание:
    Значение данного типа применяются, когда необходимо использовать пустое значение, не принадлежащее ни к одному другому типу. Например, такое значение изначально имеют реквизиты с составным типом значения. Существует одно единственное значение данного типа, задаваемое литералом.
    Литералы:
    Неопределено (Undefined)
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. При XDTO сериализации Неопределено представляется в XML различным способом для элементов и атрибутов. Для элементов записывает атрибут nil пространства имен {http://www.w3.org/2001/XMLSchema-instance} со значением true. Для атрибутов отсутствием атрибута.

  3. #3
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Число (Number)

    Число (Number)
    Описание:
    Числовым типом может быть представлено любое десятичное число. Над данными числового типа определены основные арифметические операции: сложение, вычитание, умножение и деление. Максимально допустимая разрядность числа 38 знаков.
    Литералы:
    Набор цифр, написанных непосредственно в тексте модуля вида: [+|-]{0|1|2|3|4|5|6|7|8|9}[.{0|1|2|3|4|5|6|7|8|9}] В качестве разделителя целой и дробной части используется "." (точка).
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO: может быть любым из перечисленных: decimal, double, float.

  4. #4
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Строка (String)

    Строка (String)
    Описание:
    Значения данного типа содержат строку в формате Unicode произвольной длины.
    Литералы:
    Литералы строкового типа представляют собой набор символов заключенных в кавычки. Для задания в строке символа " (кавычка) необходимо записать две кавычки подряд. Кроме того, допускаются "многострочные" строковые константы. В исходном тексте многострочные константы могут задаваться двумя способами:
    • Между фрагментами, представляющими отдельные строки многострочной строки, не должно встречаться никаких символов, за исключением пробелов, переводов строки и строк комментариев.
    • Каждая отдельная составляющая не замыкается кавычками, а на каждой последующей строке помещен символ переноса строки | (вертикальная черта). В этом варианте комментарии допускаются, если строка начинается с символа комментария //.
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO: может быть любым из перечисленных: string, anySimpleType, anyURI, duration, gDay, gMonth, gMonthDay, gYear, gYearMonth, NOTATION.

  5. #5
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Дата (Date)

    Дата (Date)
    Описание:
    Значения данного типа содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до секунды.
    Литералы:
    Строка цифр, заключенная в одинарные кавычки вида: 'ГГГГММДДччммсс', где:
    • ГГГГ - четыре цифры года (включая тысячелетие и век);
    • ММ - две цифры месяца;
    • ДД - две цифры даты;
    • чч - две цифры часа (в 24-х часовом формате);
    • мм - две цифры минут;
    • сс - две цифры секунд;
    Во встроенном языке в литерале типа Дата обязательно должно задаваться значение года, месяца и дня. Для задания даты соответствующей началу отсчета достаточно указать '00010101'. Допускается при указании литералов типа Дата опускать последние символы (секунды, минуты, часы и т.д.). Это означает, что данные параметры будут равны нулю (для времени) или единице (для даты). В литерале даты допускается использование различных разделителей.
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO: может быть любым из перечисленных: dateTime, date, time.

  6. #6
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Булево (Boolean)

    Булево (Boolean)
    Описание:
    Значения данного типа имеют два значения Истина и Ложь, задаваемых соответствующими литералами.
    Значения данного типа возвращаются в качестве результата вычисления логических выражений.
    Литералы:
    Истина (True)
    Ложь (False)
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO: Boolean.


    Истина (True)

    Истина (True)
    Описание:
    Литерал для указания значения типа Булево.

    Ложь (False)

    Ложь (False)
    Описание:
    Литерал для указания значения типа Булево.

  7. #7
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Тип (Type)

    Тип (Type)
    Описание:
    Значения данного типа используются для идентификации типов значений. Это необходимо для определения и сравнения типов. Данный тип не имеет литералов и возвращается функциями встроенного языка ТипЗнч и Тип.
    Доступность: Возможен обмен с сервером.
    Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту определяется в пространстве имен {http://v8.1c.ru/8.1/data/core}. Имя типа XDTO: Type.

  8. #8
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Инструкции препроцессору

    Инструкции препроцессору
    Для указания разрешения использования процедур и функций общих модулей и модулей объектов используют инструкции препроцессору.
    Синтаксис:
    #Если <Логическое выражение> Тогда
    #ИначеЕсли <Логическое выражение> Тогда

    #Иначе
    #КонецЕсли

    где:
    <Логическое выражение> = [НЕ] <Символ препроцессора> [<Булева операция> [НЕ] <Символ препроцессора> [<Булева операция> [НЕ] <Символ препроцессора>]…]
    <Символ препроцессора> = {НаКлиенте | НаСервере | ТолстыйКлиентОбычноеПриложение | ТолстыйКлиентУправляемоеПриложение | Клиент | Сервер | ВнешнееСоединение }
    <Булева операция> = {И | ИЛИ}

    Используемые термы:
    #Если (#If)
    #Тогда (#Then)
    #ИначеЕсли (#ElsIf)
    #Иначе (#Else)
    #КонецЕсли (#EndIf)
    Клиент (Client)
    НаКлиенте (AtClient)
    НаСервере (AtServer)
    ТолстыйКлиентОбычноеПриложение(ThickClientOrdinaryApplication)
    ТолстыйКлиентУправляемоеПриложение (ThickClientManagedApplication)
    Сервер (Server)
    ВнешнееСоединение (ExternalConnection)
    ТонкийКлиент (ThinClient)
    ВебКлиент (WebClient)
    И (AND)
    ИЛИ (OR)
    НЕ (NOT)

    Регистр букв (строчные или заглавные) при написании не имеет значения.
    Описание использования:
    В варианте клиент-сервер
    Если используется клиент–серверный вариант запуска системы 1С:Предприятие, то можно организовывать выполнение различных процедур и функций на сервере приложения или на клиентском месте.
    Для выполнения на сервере (инструкции Сервер и НаСервере равнозначны):
    #Если НаСервере Тогда

    #КонецЕсли

    Для того, чтобы процедура присутствовала и была вызвана на стороне сервера, фрагмент кода должен выглядеть следующим образом:
    #Если Сервер Тогда
    Процедура Проц1() Экспорт

    КонецПроцедуры
    #КонецЕсли

    Важно! В приведенном тексте ВСЯ процедура, а не ее часть находится внутри блока #Если Сервер Тогда … #КонецЕсли.
    При запуске конфигурации на выполнение производится загрузка и компиляция конфигурации. Экземпляры всех общих модулей создаются как на серверной, так и на клиентской стороне. Если в каком-то из общих модулей содержится приведенный фрагмент кода, то он в соответствии с инструкцией препроцессора #Если Сервер Тогда … #КонецЕсли будет скомпилирован только на стороне сервера, а на стороне клиента данный фрагмент «выпадет» из компилируемого текста и, таким образом, процедура на стороне клиента не будет представлена совсем.
    Далее, при компиляции на стороне клиента модулей, в которых содержится обращение к данной процедуре, будет произведен ее поиск на стороне клиента. На стороне клиента таковой процедуры нет, следовательно, она не будет найдена. Тогда будет произведен поиск процедуры в общих модулях на стороне сервера, где она будет обнаружена и все вызовы будут переправляться для выполнения на сервер 1С:Предприятия.
    Если блок #Если Сервер Тогда … #КонецЕсли включает только часть процедуры, то процедура будет присутствовать как на стороне клиента, так и на стороне сервера. Только на клиентской стороне она будет без той части, которая заключена в блок, поэтому результат выполнения процедуры может зависеть от того, где обрабатывается вызов этой процедуры.
    Для выполнения на клиентском месте в обычном и управляемом режиме:
    #Если НаКлиенте Тогда

    #КонецЕсли

    или
    #Если Клиент Тогда

    #КонецЕсли

    Инструкция препроцессора НаКлиенте (AtClient) определена для всех клиентских приложений. Для тонкой подстройки модуля под конкретное клиентское приложение дополнительно введены инструкции ТолстыйКлиентОбычноеПриложение (ThickClientOrdinaryApplication), ТолстыйКлиентУправляемоеПриложение (ThickClientManagedApplication), ТонкийКлиент (ThinClient) и ВебКлиент (WebClient), которые определены в соответствующих приложениях.
    Для выполнения на клиенте:
    #Если ТолстыйКлиентОбычноеПриложение Тогда

    #КонецЕсли
    #Если ТолстыйКлиентУправляемоеПриложение Тогда

    #КонецЕсли

    Для выполнения на тонком клиенте:
    #Если ТонкийКлиент Тогда

    #КонецЕсли

    Для выполнения на веб-клиенте:
    #Если ВебКлиент Тогда

    #КонецЕсли

    В файл–серверном варианте
    В обычном клиенте в обычном и управляемом режиме доступны НаКлиенте, Клиент, ТолстыйКлиентОбычноеПриложение, ТолстыйКлиентУправляемоеПриложение , НаСервере, Сервер.
    В файловом варианте инструкции препроцессору #Если Сервер…, #Если Клиент…, #Если ТолстыйКлиентОбычноеПриложение или #Если ТолстыйКлиентУправляемоеПриложение… определены всегда, поэтому экземпляр кода будет присутствовать всегда.
    В тонком клиенте доступны – ТонкийКлиент, НаКлиенте, Клиент.
    На серверной части тонкого клиента – Сервер, НаСервере.
    Во внешнем соединении – ВнешнееСоединение, НаСервере, Сервер.
    В сессии СОМ-соединения
    Для включения возможности использования процедур и функций в сессии внешнего соединения применяется инструкция препроцессора.
    #Если ВнешнееСоединение Тогда

    #КонецЕсли

  9. #9
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Директивы компиляции

    Директивы компиляции
    Каждая процедура и функция модуля формы, модуля команды и общего модуля управляемого приложения предваряется директивой компиляции, определяющей среду исполнения данной процедуры. Директива предваряется символом "&". Допустимые директивы:
    • &НаКлиенте (&AtClient) — определяет клиентскую процедуру (функцию);
    • &НаСервере (&AtServer) — определяет серверную процедуру (функцию);
    • &НаСервереБезКонтекста (&AtServerNoContext) — определяет серверную процедуру (функцию), исполняемую на сервере вне контекста формы. Переменные не могут быть внеконтекстными. В таких методах недоступен контекст формы (включая данные формы). Допустимыми являются вызовы только других внеконтекстных методов. При вызове этих методов не выполняется передача данных формы на сервер и обратно. Применение внеконтекстных методов позволяет существенно уменьшить объем передаваемых данных при вызове серверной процедуры из среды клиентского приложения;
    • &НаКлиентеНаСервереБезКонтекста (&AtClientAtServerNoContext) — определяет процедуру (функцию), исполняемую в модуле формы на клиенте и на сервере, не имеющую доступа к контексту формы, данным формы, переменным, но имеющую доступ к процедурам и функциям общих модулей – серверных, не глобальных и серверных и клиентских одновременно. Сама процедура (функция) доступна для клиентский, серверных контекстных и неконтекстных процедур и функций модуля формы. Из серверных внеконтекстных методов формы допускается вызов серверных методов общих модулей;
    • &НаКлиентеНаСервере (&AtClientAtServer) — определяет процедуру (функцию), исполняемую в модуле команды, выполняемую на клиенте и на сервере, имеющую доступ к процедурам и функциям общих модулей – серверных, не глобальных и серверных и клиентских одновременно, не имеющую доступ к переменным. Сама процедура (функция) доступна для клиентских серверных процедур и функций модуля команды.
    Клиентская процедура (функция) исполняется в среде клиентского приложения. В такой процедуре доступен клиентский контекст формы и вызовы любых процедур модуля.
    Серверная процедура (функция) исполняется в среде серверного приложения. В такой процедуре доступны данные формы, доступен серверный контекст формы и вызовы серверных и серверных внеконтекстных процедур модуля. При вызове такой процедуры данные формы будут передаваться с клиента на сервер и обратно (по окончанию вызова).
    Серверная процедура (функция), исполняемая вне контекста формы, (внеконтекстная) исполняется в среде серверного приложения. В такой процедуре (функции) недоступен контекст формы (включая данные формы). Допустимыми являются вызовы только других внеконтекстных процедур (функций). При вызове этих процедур (функций) не выполняется передача данных формы на сервер и обратно. Применение внеконтекстных процедур (функций) позволяет существенно уменьшить объем передаваемых данных при вызове серверной процедуры (функции) из среды клиентского приложения.
    Отсутствие директивы компиляции перед процедурой (функцией) означает использование директивы по умолчанию. Директивой по умолчанию является &НаСервере. Не допускается использование нескольких директив компиляции перед одной процедурой (функцией). Не допускается наличие одноименных процедур (функций), отличающихся только директивами компиляции.
    В модуле управляемой формы допускается использование инструкций препроцессору. Рекомендуется использовать инструкции препроцессора только внутри процедур (функций). Для понимания результата при "пересечении" инструкциями препроцессора границ процедур (функций) следует учитывать, что обработка инструкций препроцессора выполняется до обработки директив компиляции.
    В модуле команды предопределенная процедура-обработчик ОбработатьКоманду должна предваряться директивой &НаКлиенте, так как выполнение команды происходит в клиентском приложении.
    Модуль формы
    В модуле формы доступны директивы компиляции – &НаКлиенте, &НаСервере, &НаСервереБезКонтекста, &НаКлиентеНаСервереБезКонтекста.
    Модуль команды
    В модуле команды доступны директивы компиляции – &НаКлиенте, &НаСервере, &НаКлиентеНаСервере.
    Общий модуль
    В общем модуле доступны директивы компиляции – &НаКлиенте, &НаСервере.

Закрытая тема

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения


Навигация по сайту:
, 1c, 1с 8.2, 1с 8.3, Скачать 1с, 1с бухгалтерия, 1с предприятие, Программа 1с,
1с торговля, 1с управление, 1с зарплата, Обновление 1с, Миста, Программирование 1с,

Положение об ответственности
Связь с администрацией erpsolution.ru@yandex.ru