Для удобного просмотра сайта рекомендуется использовать Google Chrome.


Закрытая тема
Страница 1 из 2 1 2 Следующая ПоследняяПоследняя
Показано с 1 по 10 из 15

Тема: Операторы

  1. #1
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию Операторы

    ? (вычислить выражение по условию)

    ? (вычислить выражение по условию)
    Синтаксис:
    ?(<Логическое выражение>, <Выражение 1>, <Выражение 2>)
    Параметры:
    <Логическое выражение>
    Логическое выражение, результат вычисления которого определяет одно из результирующих выражений, которые будут вычислены. Если результат его вычисления Истина, то будет вычисляться <Выражение 1>. Если результат Ложь – то <Выражение 2>.
    <Выражение 1>
    Результирующее выражение, которое будет вычисляться, если результат логического выражения Истина.
    <Выражение 2>
    Результирующее выражение, которое будет вычисляться, если результат логического выражения Ложь.
    Возвращаемое значение:
    Результат вычисления одного из результирующих выражений.
    Описание:
    Позволяет вычислить одно из двух заданных выражений в зависимости от результата вычисления логического выражения.

  2. #2
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Выполнить (Execute)

    Выполнить (Execute)
    Синтаксис:
    Выполнить(<Строка>)
    Параметры:
    <Строка>
    Строка, содержащая текст исполняемого кода.
    Описание:
    Позволяет выполнить фрагмент кода, который передается ему в качестве строкового значения.
    Примечание:
    В режиме запуска веб-клиент оператор не поддерживается и его вызов игнорируется.

  3. #3
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Для (For)

    Для (For)
    Синтаксис:
    Для <Имяпеременной> = <Выражение 1> По <Выражение 2> Цикл
    // Операторы
    [Прервать;]
    // Операторы
    [Продолжить;]
    // Операторы
    КонецЦикла;
    Англоязычный синтаксис:
    For <Имя переменной> = <Выражение 1> To <Выражение 2> Do
    // Операторы
    [Break;]
    // Операторы
    [Continue;]
    // Операторы
    EndDo;
    Параметры:
    <Имя переменной>
    Идентификатор переменной (счетчика цикла), значение которой автоматически увеличивается на 1 при каждом повторении цикла. Так называемый счетчик цикла.
    <Выражение 1>
    Числовое выражение, которое задает начальное значение, присваиваемое счетчику цикла при первом проходе цикла.
    По
    Синтаксическая связка для параметра <Выражение 2>.
    <Выражение 2>
    Максимальное значение счетчика цикла. Когда переменная <Имя переменной> становится больше чем <Выражение 2>, выполнение оператора цикла Для прекращается.
    Цикл
    Операторы, следующие за ключевым словом Цикл выполняются, пока значение переменной <Имя переменной> меньше или равно значения <Выражение 2>.
    // Операторы
    Исполняемый оператор или последовательность таких операторов.
    Прервать
    Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.
    Продолжить
    Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.
    КонецЦикла
    Ключевое слово, которое завершает структуру оператора цикла.
    Описание:
    Оператор цикла Для предназначен для циклического повторения операторов, находящихся внутри конструкции Цикл – КонецЦикла. Перед началом выполнения цикла значение <Выражение 1> присваивается переменной <Имя переменной>. Значение <Имя переменной> автоматически увеличивается при каждом проходе цикла. Величина приращения счетчика при каждом выполнении цикла равна 1. Цикл выполняется, пока значение переменной <Имя_переменной> меньше или равно значению <Выражение 2>. Условие выполнения цикла всегда проверяется в начале, перед выполнением цикла.

  4. #4
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Для каждого (For each)

    Для каждого (For each)
    Синтаксис:
    Для каждого <Имя переменной 1> Из <Имя переменной 2> Цикл
    // Операторы
    [Прервать;]
    // Операторы
    [Продолжить;]
    // Операторы
    КонецЦикла;
    Англоязычный синтаксис:
    For each <Имя переменной 1> In <Имя переменной 2> Do
    // Операторы
    [Break;]
    // Операторы
    [Continue;]
    // Операторы
    EndDo;
    Параметры:
    <Имя переменной 1>
    Переменная, которой при каждом повторении цикла присваивается значение очередного элемента коллекции.
    Из
    Синтаксическая связка для параметра <Имя переменной 2>.
    <Имя переменной 2>
    Переменная или выражение, предоставляющее коллекцию. Элементы этой
    коллекции будут присваиваться параметру <Имя переменной 1>.
    Цикл
    Операторы, следующие за ключевым словом Цикл выполняются, пока значение переменной <Имя переменной> меньше значения <Выражение 2>.
    // Операторы
    Исполняемый оператор или последовательность таких операторов.
    Прервать
    Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.
    Продолжить
    Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.
    КонецЦикла
    Ключевое слово, которое завершает структуру оператора цикла.
    Описание:
    Оператор цикла Для каждого предназначен для циклического обхода коллекций значений. При каждой итерации цикла возвращается новый элемент коллекции. Обход осуществляется до тех пор, пока не будут перебраны все элементы коллекции.

  5. #5
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Если (If)

    Если (If)
    Синтаксис:
    Если <Логическое выражение> Тогда
    // Операторы
    [ИначеЕсли <Логическое выражение> Тогда]
    // Операторы
    [Иначе]
    // Операторы
    КонецЕсли;
    Англоязычный синтаксис:
    If <Логическое выражение> Then
    // Операторы
    [ElsIf <Логическое выражение> Then]
    // Операторы
    [Else ]
    // Операторы
    EndIf;
    Параметры:
    <Логическое выражение>
    Логическое выражение.
    Тогда
    Операторы, следующие за Тогда выполняются, если результатом логического выражения является значение Истина.
    // Операторы
    Исполняемый оператор или последовательность таких операторов.
    ИначеЕсли
    Логическое выражение, следующее за ключевым словом ИначеЕсли, вычисляется только тогда, когда условия в Если и всех предшествующих ИначеЕсли оказались равны Ложь.
    Операторы, следующие за конструкцией ИначеЕсли — Тогда, выполняются, если результат логического выражения в данном ИначеЕсли равен Истина.
    Иначе
    Операторы, следующие за ключевым словом Иначе, выполняются, если результаты логических выражений в конструкции Если и всех предшествующих конструкцях ИначеЕсли оказались равны Ложь.
    КонецЕсли
    Ключевое слово, которое завершает структуру оператора условного выполнения.
    Описание:
    Оператор Если управляет выполнением программы, основываясь на результате одного или более логических выражений. Оператор может содержать любое количество групп операторов, возглавляемых конструкциями ИначеЕсли — Тогда.

  6. #6
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Новый (New)

    Новый (New)
    Синтаксис (вариант 1):
    Новый <Идентификатор типа>[(<Парам1>, <Парам2>, …)]
    Параметры:
    Идентификатор типа
    Указывается идентификатор типа, значение которого создается.
    <Парам1>, <Парам2>, …
    После идентификатора типа в скобках могут указываться параметры, если они определены в конструкторах для данного типа. Допустимое количество параметров и их назначение указывается в описании конструкторов объекта.
    Синтаксис (вариант 2):
    Новый(<Тип>[, <ПараметрыКонструктра>])
    Параметры:
    Тип
    Имя типа или значение типа Тип
    ПараметрыКонструктора
    Массив параметров конструктора
    Описание:
    Оператор позволяет создать значение указанного типа. Допустим только для тех типов, для которых разрешено создание с помощью данного оператора (подробнее см. описание объектов языка).
    Для прикладных объектов необходимо использовать функциональную форму оператора Новый (вариант 2), так как при проверке модулей в конфигураторе не определены типы для прикладных объектов.
    Пример1:
    СписокСохранения = Новый Структура;
    ХранилищеДанных = Новый ХранилищеЗначения(СписокСохранения);
    Пример2:
    ТипЗначения = Тип("КвалификаторыСтроки");
    Параметры = Новый Массив(2);
    Параметры[0]= 20;
    Параметры[1]= ДопустимаяДлина.Переменная;
    КвСтр = Новый(ТипЗначения, Параметры);

  7. #7
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Перейти (Goto)

    Перейти (Goto)
    Синтаксис:
    Перейти <Метка>;
    Англоязычный синтаксис:
    Goto <Метка>;
    Описание:
    Безусловная передача управления на другой оператор программы. Передает управление от одного оператора к другому. Область действия оператора ограничивается программным модулем, процедурой или функцией; он не может передать управление за пределы программного модуля, процедуры или функции.

  8. #8
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Перем (Var)

    Перем (Var)
    Синтаксис:
    Перем <Имя переменной 1> [Экспорт] [, <Имя переменной 2> [Экспорт], …]
    Англоязычный синтаксис:
    Var <Имя переменной 1> [Export] [, <Имя переменной 2> [Export], …]
    Параметры:
    <Имя переменной 1>[, <Имя переменной 2>, …]
    Задается имя или имена объявляемых переменных.
    Экспорт
    Необязательное ключевое слово.
    Указывает, что данная переменная доступна при обращении к контексту этого модуля из других модулей. Не имеет смысла при объявлении переменных отдельных процедур или функций.
    Описание:
    Позволяет в явном виде объявить переменную.

  9. #9
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Пока (While)

    Пока (While)
    Синтаксис:
    Пока <Логическое выражение> Цикл
    // Операторы
    [Прервать;]
    // Операторы
    [Продолжить;]
    // Операторы
    КонецЦикла;
    Англоязычный синтаксис:
    While <Логическое выражение> Do
    // Операторы
    [Break;]
    // Операторы
    [Continue;]
    // Операторы
    EndDo;
    Параметры:
    <Логическое выражение>
    Логическое выражение.
    Цикл
    Операторы, следующие за ключевым словом Цикл, выполняются, пока результат логического выражения равен Истина.
    // Операторы
    Исполняемый оператор или последовательность таких операторов.
    Прервать
    Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.
    Продолжить
    Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла.
    Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.
    КонецЦикла
    Ключевое слово, которое завершает структуру оператора цикла.
    Описание:
    Оператор цикла Пока предназначен для циклического повторения операторов, находящиеся внутри конструкции Цикл – КонецЦикла. Цикл выполняется, пока логическое выражение равно Истина. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

  10. #10
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Попытка (Try)

    Попытка (Try)
    Синтаксис:
    Попытка
    // Операторы попытки
    Исключение
    // Операторы
    исключения
    [ВызватьИсключение;]
    // Операторы исключения
    КонецПопытки;
    Англоязычный синтаксис:
    Try
    // Операторы попытки
    Except
    // Операторы исключения
    [Raise;]
    // Операторы исключения
    EndTry;
    Параметры:
    // Операторы попытки
    Исполняемый оператор или последовательность таких операторов.
    Исключение
    Операторы, следующие за ключевым словом Исключение выполняются, если при выполнении последовательности операторов произошла ошибка времени выполнения.
    // Операторы исключения
    Исполняемый оператор или последовательность операторов, которые обрабатывают исключительную ситуацию.
    ВызватьИсключение
    Оператор позволяет вызвать исключение в тех случаях, когда несмотря на отработку исключительной ситуации операторами исключения необходимо прервать выполнение модуля с ошибкой времени выполнения. Оператор допустим только внутри операторных скобок Исключение – КонецПопытки.
    Выполнение данного оператора прекращает выполнение последовательности операторов исключения и производит поиск более "внешнего" обработчика исключения (при вложенных попытках). Если таковой есть, то управление передается на его первый оператор. Если нет, то исключительная ситуация обрабатывается системно, выдается сообщение о первоначально возникшей ошибке, а выполнение модуля прекращается.
    КонецПопытки
    Ключевое слово, которое завершает структуру оператора обработки исключительных ситуаций.
    Описание:
    Оператор Попытка управляет выполнением программы, основываясь на возникающих при выполнении модуля ошибочных (исключительных) ситуациях, и определяет обработку этих ситуаций. В качестве ошибочных (исключительных) ситуаций воспринимаются ошибки времени выполнения модуля. Не предусмотрено определяемых пользователем исключений.
    Если при выполнении последовательности операторов попытки произошла ошибка времени выполнения, то выполнение оператора, вызвавшего ошибку, прерывается и управление передается на первый оператор последовательности операторов исключения. При этом управление будет передано даже в том случае, если ошибку вызвал оператор, находящийся в процедуре или функции, вызванной из операторов попытки. Если ошибка произошла в вызванной процедуре или функции, то ее выполнение будет прервано, а локальные переменные – уничтожены. Это справедливо для любой вложенности вызовов. После выполнения последовательности операторов исключения управление передается на следующий за ключевым словом КонецПопытки оператор. Если же последовательность операторов попытки выполнилась без ошибок, то последовательность операторов исключения будет пропущена и управление также
    будет продолжено с оператора, следующего за ключевым словом КонецПопытки.
    Конструкции Попытка – Исключение – КонецПопытки могут быть вложенными. При этом, при возникновении исключительной ситуации управление передается на тот обработчик, в попытке которого произошла ошибка. Если же в последовательности операторов исключения этого обработчика выполняется оператор ВызватьИсключение, выполнение передается вышестоящему обработчику исключения и так далее. Если вышестоящего обработчика нет, исключительная ситуация обрабатывается системно с прекращением выполнения программного модуля.

Закрытая тема
Страница 1 из 2 1 2 Следующая ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Похожие темы

  1. 8908, 8950 - это какие операторы?
    от maverick в разделе Оффтопик
    Ответов: 0
    Последнее сообщение: 27.08.2010, 23:00

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения


Навигация по сайту:
, 1c, 1с 8.2, 1с 8.3, Скачать 1с, 1с бухгалтерия, 1с предприятие, Программа 1с,
1с торговля, 1с управление, 1с зарплата, Обновление 1с, Миста, Программирование 1с,

Положение об ответственности
Связь с администрацией erpsolution.ru@yandex.ru