Здравствуйте! Помогите пожалуйста! Мне нужно во внешнюю печатную форму Счет Фактура вывести Код_Поставщика для конкретного контрагента. Этот код нужно получить из регистра сведений ЗначенияСвойствОбъектов(Измерения:Объект тип:ДокументСсылка, СправочникСсылка; Свойство тип:ПланВидовХарактеристикСсылка.СвойстваОбъектов;
Ресурсы: Значение тип:Характеристика.СвойстваОбъектов).
Я для справочника Контрагенты установила Свойство КодПоставщика. Теперь значение данного свойства мне необходимо получить для конкретного контрагента и вывести в печатную форму.
Не знаю как правильно программно реализовать.

Код 1c:
СвойствоКод = "Код поставщика";    
    Свойство = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию(СвойствоКод, Истина);
    Если Свойство <> Неопределено Тогда
        Отбор = Новый Структура();
        Отбор.Вставить(???);//отбор же мне нужно делать по контрагенту?
 
        Рег = РегистрыСведений.ЗначенияСвойствОбъектов;
        ТекРег = Рег.ПолучитьПоследнее( ,отбор);
    КонецЕсли;

==========================


Здравствуйте! Я все по тому же вопросу. Я попробовала сделать запросом, но в параметр макета КодПоставщика ничего не выводится.

Код 1c:
Функция СобратьДанныеПоРеализацияТоваровУслуг(ДокОснование)  Экспорт
 
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);
    Запрос.УстановитьПараметр("ПустойКонтрагент",  Справочники.Контрагенты.ПустаяСсылка());
 
    Запрос.Текст = "ВЫБРАТЬ
                   |    РеализацияТоваровУслуг.Организация,
                   |    РеализацияТоваровУслуг.Организация КАК Поставщик,
                   |    ВЫБОР
                   |        КОГДА ЕСТЬNULL(РеализацияТоваровУслуг.Грузоотправитель, &ПустойКонтрагент) = &ПустойКонтрагент
                   |            ТОГДА ""он же""
                   |        ИНАЧЕ РеализацияТоваровУслуг.Грузоотправитель
                   |    КОНЕЦ КАК Грузоотправитель,
                   |    РеализацияТоваровУслуг.Подразделение КАК Подразделение,
                   |    РеализацияТоваровУслуг.Контрагент КАК Покупатель,
                   |    ВЫБОР
                   |        КОГДА ЕСТЬNULL(РеализацияТоваровУслуг.Грузополучатель, &ПустойКонтрагент) = &ПустойКонтрагент
                   |            ТОГДА РеализацияТоваровУслуг.Контрагент
                   |        ИНАЧЕ РеализацияТоваровУслуг.Грузополучатель
                   |    КОНЕЦ КАК Грузополучатель,
                   |    РеализацияТоваровУслуг.СуммаДокумента КАК Сумма,
                   |    РеализацияТоваровУслуг.ВалютаДокумента КАК Валюта,
                   |    РеализацияТоваровУслуг.УчитыватьНДС КАК УчитыватьНДС,
                   |    РеализацияТоваровУслуг.СуммаВключаетНДС КАК СуммаВключаетНДС
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                   |ГДЕ
                   |    РеализацияТоваровУслуг.Ссылка = &ДокументОснование";
 
 
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
///////////вот мой запрос(работает правильно, я в консоли его проверяла) 
    Свойство = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Код поставщика");
    Запрос = Новый Запрос();
    Запрос.Текст = 
 
      "ВЫБРАТЬ
      |    ЗначенияСвойствОбъектов.Значение КАК КодКонтрагента
      |ИЗ
      |    РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
      |ГДЕ
      |    ЗначенияСвойствОбъектов.Свойство.Ссылка = &Ссылка
      |    И ЗначенияСвойствОбъектов.Объект = &Объект" ;
      Запрос.УстановитьПараметр("Объект",Шапка.Покупатель);//контрагента я пытаюсь взять из предыдущего запроса 
      Запрос.УстановитьПараметр("Ссылка",Свойство); 
      Результат = Запрос.Выполнить().Выбрать();
/////////// 
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);
    Запрос.УстановитьПараметр("ПустаяЕдиница", Справочники.ЕдиницыИзмерения.ПустаяСсылка());
    Запрос.Текст = "ВЫБРАТЬ
                   |    РеализацияТоваровУслугТовары.Номенклатура КАК Товар,
                   |    ВЫРАЗИТЬ(РеализацияТоваровУслугТовары.Номенклатура.НаименованиеПолное КАК СТРОКА(200)) КАК ТоварНаименование,
                   |    РеализацияТоваровУслугТовары.СерияНоменклатуры.СтранаПроисхождения КАК СтранаПроисхождения,
                   |    РеализацияТоваровУслугТовары.СерияНоменклатуры.СтранаПроисхождения.НаименованиеПолное КАК ПредставлениеСтраны,
                   |    РеализацияТоваровУслугТовары.СерияНоменклатуры.НомерГТД КАК НомерГТД,
                   |    РеализацияТоваровУслугТовары.СерияНоменклатуры.НомерГТД.Представление КАК ПредставлениеГТД,
                   |    РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Представление КАК ЕдиницаИзмерения,
                   |    РеализацияТоваровУслугТовары.Количество КАК Количество,
                   |    РеализацияТоваровУслугТовары.Цена КАК Цена,
                   |    РеализацияТоваровУслугТовары.СтавкаНДС КАК СтавкаНДС,
                   |    РеализацияТоваровУслугТовары.СуммаНДС КАК СуммаНДС,
                   |    РеализацияТоваровУслугТовары.Сумма КАК Сумма,
                   |    РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры КАК Характеристика,
                   |    РеализацияТоваровУслугТовары.СерияНоменклатуры КАК Серия,
                   |    РеализацияТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
                   |    1 КАК НомерТЧ,
                   |    НоменклатураКонтрагентов.АртикулНоменклатурыКонтрагента КАК Артикул
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                   |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.НоменклатураКонтрагентов КАК НоменклатураКонтрагентов
                   |        ПО (НоменклатураКонтрагентов.Номенклатура.Ссылка = РеализацияТоваровУслугТовары.Номенклатура.Ссылка)
                   |            И (НоменклатураКонтрагентов.Контрагент = РеализацияТоваровУслугТовары.Ссылка.Контрагент)
                   |ГДЕ
                   |    РеализацияТоваровУслугТовары.Ссылка = &ДокументОснование
                   |
                   |ОБЪЕДИНИТЬ ВСЕ
                   |
                   |ВЫБРАТЬ
                   |    РеализацияТоваровУслугУслуги.Номенклатура,
                   |    РеализацияТоваровУслугУслуги.Содержание,
                   |    """",
                   |    NULL,
                   |    NULL,
                   |    """",
                   |    РеализацияТоваровУслугУслуги.Номенклатура.ЕдиницаХраненияОстатков.Представление,
                   |    ВЫБОР
                   |        КОГДА РеализацияТоваровУслугУслуги.Номенклатура.ЕдиницаХраненияОстатков = &ПустаяЕдиница
                   |            ТОГДА 0
                   |        ИНАЧЕ РеализацияТоваровУслугУслуги.Количество
                   |    КОНЕЦ,
                   |    РеализацияТоваровУслугУслуги.Цена,
                   |    РеализацияТоваровУслугУслуги.СтавкаНДС,
                   |    РеализацияТоваровУслугУслуги.СуммаНДС,
                   |    РеализацияТоваровУслугУслуги.Сумма,
                   |    NULL,
                   |    NULL,
                   |    РеализацияТоваровУслугУслуги.НомерСтроки,
                   |    2,
                   |    NULL
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслугУслуги
                   |ГДЕ
                   |    РеализацияТоваровУслугУслуги.Ссылка = &ДокументОснование
                   |
                   |УПОРЯДОЧИТЬ ПО
                   |    НомерТЧ,
                   |    НомерСтроки";
 
 
    ВыборкаСтрокТовары = Запрос.Выполнить().Выбрать();
 
    ДанныеДляПечати = Новый Структура();
    ДанныеДляПечати.Вставить("Организация",      Шапка.Организация);
    ДанныеДляПечати.Вставить("Номер",            СсылкаНаОбъект.Номер);
    ДанныеДляПечати.Вставить("Дата",             СсылкаНаОбъект.Дата);
    ДанныеДляПечати.Вставить("Поставщик",        Шапка.Поставщик);
    ДанныеДляПечати.Вставить("Грузоотправитель", Шапка.Грузоотправитель);
    ДанныеДляПечати.Вставить("Подразделение",    Шапка.Подразделение);
    ДанныеДляПечати.Вставить("Покупатель",       Шапка.Покупатель);
    ДанныеДляПечати.Вставить("Грузополучатель",  Шапка.Грузополучатель);
    ДанныеДляПечати.Вставить("Сумма",            Шапка.Сумма);
    ДанныеДляПечати.Вставить("Валюта",           Шапка.Валюта);
    ДанныеДляПечати.Вставить("УчитыватьНДС",     Шапка.УчитыватьНДС);
        ///////// 
        ДанныеДляПечати.Вставить("КодКонтрагента",   Результат.КодКонтрагента);
        ////////     
Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизации(Шапка.Организация, СсылкаНаОбъект.Дата,);
    ДанныеДляПечати.Вставить(?(ЭтоПБОЮЛ(Шапка.Поставщик), "ФИОПБОЮЛ", "ФИОРуководителя"), Руководители.Руководитель);
    ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", Руководители.ГлавныйБухгалтер);
 
    Товары = ИнициализацияТаблицыСтрок();
 
    Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл
        Строчка = Товары.Добавить();
        Строчка.Товар               = ВыборкаСтрокТовары.Товар;
        Строчка.Артикул              = ВыборкаСтрокТовары.Артикул;
        Строчка.ТоварНаименование   = СокрЛП(ВыборкаСтрокТовары.ТоварНаименование) + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары);
        Строчка.СтранаПроисхождения = ВыборкаСтрокТовары.СтранаПроисхождения;
        Строчка.ПредставлениеСтраны = ?(Не ЗначениеЗаполнено(ВыборкаСтрокТовары.ПредставлениеСтраны), ВыборкаСтрокТовары.СтранаПроисхождения, ВыборкаСтрокТовары.ПредставлениеСтраны);
        Строчка.НомерГТД            = ВыборкаСтрокТовары.НомерГТД;
        Строчка.ПредставлениеГТД    = ВыборкаСтрокТовары.ПредставлениеГТД;
        Строчка.Количество          = ВыборкаСтрокТовары.Количество;
        Строчка.ЕдиницаИзмерения    = ВыборкаСтрокТовары.ЕдиницаИзмерения;
        Строчка.СуммаВключаетНДС    = Шапка.СуммаВключаетНДС;
        Строчка.Цена = ?(ВыборкаСтрокТовары.Цена <> 0, ?(НЕ Шапка.СуммаВключаетНДС,?(ВыборкаСтрокТовары.Количество = 0, 0, ВыборкаСтрокТовары.Сумма / ВыборкаСтрокТовары.Количество),ВыборкаСтрокТовары.Цена),
                         ?(ВыборкаСтрокТовары.Количество = 0, 0, (ВыборкаСтрокТовары.Сумма - ?(Шапка.СуммаВключаетНДС, ВыборкаСтрокТовары.СуммаНДС, 0)) / ВыборкаСтрокТовары.Количество));
        Строчка.СтавкаНДС           = ?(Шапка.УчитыватьНДС, ВыборкаСтрокТовары.СтавкаНДС, Перечисления.СтавкиНДС.БезНДС);
        Строчка.СуммаНДС            = ВыборкаСтрокТовары.СуммаНДС;
        Строчка.Сумма               = ВыборкаСтрокТовары.Сумма;
 
    КонецЦикла;
 
    ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);
 
    Возврат ДанныеДляПечати;
КонецФункции
 
В функции ПечатьСчетаФактуры я пытаюсь вывести полученный КодПоставщика в область макета Шапка:
Функция ПечатьСчетаФактуры(ДанныеДляПечати)
 
    ТабДокумент = Новый ТабличныйДокумент;
 
    Если СсылкаНаОбъект.Дата < '20040216' Тогда
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура575";
        Макет = ПолучитьОбщийМакет("СчетФактура575");
    ИначеЕсли СсылкаНаОбъект.Дата < '20060530' Тогда
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура84";
        Макет = ПолучитьОбщийМакет("СчетФактура84");
    Иначе
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураПолученный_СчетФактура451";
        Макет = ПолучитьМакет("СчетФактура451");
    КонецЕсли;
 
    СведенияОбПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, СсылкаНаОбъект.Дата);
    СведенияОПоставщике  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Поставщик, СсылкаНаОбъект.Дата);
    СведенияОГрузоотправителе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(?(ДанныеДляПечати.Грузоотправитель = "он же", Неопределено, ДанныеДляПечати.Грузоотправитель), СсылкаНаОбъект.Дата);
    СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Грузополучатель, СсылкаНаОбъект.Дата);
 
    ВыборкаПоТоварам = ДанныеДляПечати.ТабличнаяЧасть.Скопировать();
    ВыборкаПоТоварам.Свернуть("Товар");
 
    Если ВыборкаПоТоварам.Количество() > 0 Тогда
        ТолькоУслуги = Истина;
        Для Каждого СтрокаТовар Из ВыборкаПоТоварам Цикл
            Если (ТипЗнч(СтрокаТовар.Товар) = Тип("СправочникСсылка.Номенклатура")
               И Не СтрокаТовар.Товар.Услуга)
               Тогда
                ТолькоУслуги = Ложь;
                Прервать;
            КонецЕсли;
        КонецЦикла;
    Иначе
        ТолькоУслуги = Ложь;
    КонецЕсли;
 
    // Выводим шапку накладной 
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати);
    ЗаголовокДляПечати = ОбщегоНазначения.СформироватьЗаголовокДокумента(ДанныеДляПечати, "Счет-фактура");
    ОбластьМакета.Параметры.Номер = ЗаголовокДляПечати;
 
    Если СсылкаНаОбъект.Дата < '20040216' Тогда
        ОбластьМакета.Параметры.ПредставлениеПоставщика       = "Продавец: "                                 + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике,  "ПолноеНаименование,");
        ОбластьМакета.Параметры.АдресПоставщика               = "Адрес: "                                    + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике,  "ЮридическийАдрес,");
        ОбластьМакета.Параметры.ИННпоставщика                 = "Идентификационный номер продавца (ИНН): "   + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике,  "ИНН,", Ложь); 
        ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: "             + ?(Не ЗначениеЗаполнено(ДанныеДляПечати.Грузоотправитель), "", ?(ДанныеДляПечати.Грузоотправитель = "он же", ДанныеДляПечати.Грузоотправитель, ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузоотправителе,  "ПолноеНаименование,ФактическийАдрес,")));
        ОбластьМакета.Параметры.ПредставлениеГрузополучателя  = "Грузополучатель и его адрес: "              + ?(Не ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель), "", ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ФактическийАдрес,"));
        Строка_ПоДокументу = "";
        Для каждого ПараметрыДокуентаОплаты Из ДанныеДляПечати.ТаблицаДатОплат Цикл
            Строка_ПоДокументу = Строка_ПоДокументу+ ?(ПустаяСтрока(Строка_ПоДокументу), "К платежно-расчетному документу № ",", ")
                    +ПараметрыДокуентаОплаты.НомерПлатежноРасчетногоДокумента + " от " + Формат(ПараметрыДокуентаОплаты.ДатаПлатежноРасчетногоДокумента, "ДФ=dd.MM.yyyy");
        КонецЦикла; 
        Если ПустаяСтрока(Строка_ПоДокументу) Тогда
            Строка_ПоДокументу = "К платежно-расчетному документу № -- от --"
        КонецЕсли; 
        ОбластьМакета.Параметры.ПоДокументу                   = Строка_ПоДокументу;
 
        ОбластьМакета.Параметры.ПредставлениеПокупателя       = "Покупатель: "                               + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ПолноеНаименование,");
        ОбластьМакета.Параметры.АдресПокупателя               = "Адрес: "                                    + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ЮридическийАдрес,");
        ОбластьМакета.Параметры.ИННПокупателя                 = "Идентификационный номер покупателя (ИНН): " + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ИНН,", Ложь);
    Иначе
        Если СсылкаНаОбъект.Дата < '20090609' Тогда
            ОбластьМакета.Параметры.ПредставлениеПоставщика       = "Продавец: " + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,");
        Иначе
            ОбластьМакета.Параметры.ПредставлениеПоставщика       = "Продавец: " + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,") + 
                                                                    " (" + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "Представление,") + ")";
        КонецЕсли;
        ОбластьМакета.Параметры.АдресПоставщика               = "Адрес: "                            + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ЮридическийАдрес,");
        КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "КПП,", Ложь);
        Если  ЗначениеЗаполнено(КПП) Тогда
            КПП = "/" + КПП;
        КонецЕсли;
        ОбластьМакета.Параметры.ИННпоставщика                 = "ИНН/КПП продавца: "                 + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ИНН,", Ложь) + КПП;
        Если ТолькоУслуги Тогда
            ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: " + "-";
            ОбластьМакета.Параметры.ПредставлениеГрузополучателя  = "Грузополучатель и его адрес: "  + "-";
        Иначе
            ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: " + ?(Не ЗначениеЗаполнено(ДанныеДляПечати.Грузоотправитель), "", ?(ДанныеДляПечати.Грузоотправитель = "он же", ДанныеДляПечати.Грузоотправитель, ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузоотправителе,  "ПолноеНаименование,ФактическийАдрес,")));
            ОбластьМакета.Параметры.ПредставлениеГрузополучателя  = "Грузополучатель и его адрес: "  + ?(Не ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель), "", ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ФактическийАдрес,"));
        КонецЕсли;
        ////////////// 
        ОбластьМакета.Параметры.КодКонтрагента = ДанныеДляПечати.КодКонтрагента;
        ////////////// 
        Строка_ПоДокументу = "";
        Для каждого ПараметрыДокуентаОплаты Из ДанныеДляПечати.ТаблицаДатОплат Цикл
            Строка_ПоДокументу = Строка_ПоДокументу+ ?(ПустаяСтрока(Строка_ПоДокументу), "К платежно-расчетному документу № ",", ")
                    +ПараметрыДокуентаОплаты.НомерПлатежноРасчетногоДокумента + " от " + Формат(ПараметрыДокуентаОплаты.ДатаПлатежноРасчетногоДокумента, "ДФ=dd.MM.yyyy");
        КонецЦикла; 
        Если ПустаяСтрока(Строка_ПоДокументу) Тогда
            Строка_ПоДокументу = "К платежно-расчетному документу № -- от --"
        КонецЕсли; 
        ОбластьМакета.Параметры.ПоДокументу                   = Строка_ПоДокументу;
 
        ОбластьМакета.Параметры.ПредставлениеПокупателя       = "Покупатель: "                       + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ПолноеНаименование,");
        ОбластьМакета.Параметры.АдресПокупателя               = "Адрес: "                            + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ЮридическийАдрес,");
        КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "КПП,", Ложь);
        Если  ЗначениеЗаполнено(КПП) Тогда
            КПП = "/" + КПП;
        КонецЕсли;
        ОбластьМакета.Параметры.ИННПокупателя                 = "ИНН/КПП покупателя: "               + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбПокупателе, "ИНН,", Ложь) + КПП;
    КонецЕсли;
 
    ПроставитьПрочеркиВПустыеПоля(ОбластьМакета);
    ТабДокумент.Вывести(ОбластьМакета);

Объясните мне пожалуйста что я не так делаю!

===================================


сделай так
Код 1c:
"ВЫБРАТЬ
      |    ЗначенияСвойствОбъектов.Значение КАК КодКонтрагента
      |ИЗ
      |    РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
      |ГДЕ
      |    ЗначенияСвойствОбъектов.Свойство.Ссылка = &Ссылка;
     // |    И ЗначенияСвойствОбъектов.Объект = &Объект" ;
 
      Запрос.УстановитьПараметр("Объект",Шапка.Покупатель);//контрагента я пытаюсь взять из предыдущего запроса 
 
      Запрос.УстановитьПараметр("Ссылка",Свойство); 
      Результат = Запрос.Выполнить().Выбрать();
      Результат.Следующий();


Посмотри в отладчике есть ли что-то в Результат?

===================

Я так сделала, в отчет он выводит какую то непонятную цифру, причем одну и ту же для всех контрагентов.

======================

а для твоего контрагента из документа видимо нет записи, проверь может тот, которого ты выбираешь всё таки другой? может они только называются одинаково

ищите тогда по коду, а не по наименованию
======================

просто я до этого делала несколько свойств Код поставщика, а потом удаляла, и он берет почему то тот код, который помечен на удаление, и выводится теперь.
Спасибо вам большое вы мне очень помогли!