Есть база УТ (нетиповая, на платформе 8.1).
Задача: необходимо каждый день выгружать данные в файл .dbf (соответственно, файл сохранять в определенном месте), задача должна выполняться в клиент-серверном варианте.

Что сделано:
1) В общих модулях создала модуль РегламентныеПроцедуры (как и положено, без признака "глобальный")
2) В созданном модуле прописала процедуру ВыгрузитьКлассификатор(). Текст процедуры:

Код 1c:
Процедура ВыгрузитьКлассификатор() Экспорт
 
КаталогВыгрузки = "E:\Share";
Классификатор = Новый XBase();
Классификатор.Кодировка = КодировкаXBase.OEM;
Классификатор.поля.Добавить("GROOP1", "N", 6);
Классификатор.поля.Добавить("GROOP2", "N", 6);
Классификатор.поля.Добавить("GROOP3", "N", 6);
Классификатор.поля.Добавить("GROOP4", "N", 6);
Классификатор.поля.Добавить("GROOP5", "N", 6);
Классификатор.поля.Добавить("NAME", "S", 80);
Классификатор.СоздатьФайл(КаталогВыгрузки + "\Classif.dbf");
 
Запрос = Новый Запрос();
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    Номенклатура.Ссылка КАК Номн
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура
    |ГДЕ
    |    Номенклатура.ЭтоГруппа = &ЭтоГруппа
    |АВТОУПОРЯДОЧИВАНИЕ";
 
    Запрос.УстановитьПараметр("ЭтоГруппа", Истина);
    РезЗапроса = Запрос.Выполнить();
    Выборка = РезЗапроса.Выбрать();
    ТабКлассиф = Новый ТаблицаЗначений;
    ТабКлассиф = РезЗапроса.Выгрузить();
    ТабКлассиф.Колонки.Добавить("Groop1");
    ТабКлассиф.Колонки.Добавить("Groop2");
    ТабКлассиф.Колонки.Добавить("Groop3");
    ТабКлассиф.Колонки.Добавить("Groop4");
    ТабКлассиф.Колонки.Добавить("Groop5");
    ТабКлассиф.Колонки.Добавить("Код");
 
    Классификатор.Добавить();
    Классификатор.GROOP1 = 0;
    Классификатор.GROOP2 = 0;
    Классификатор.GROOP3 = 0;
    Классификатор.GROOP4 = 0;
    Классификатор.GROOP5 = 0;
    Классификатор.Name     = "Классификатор товаров";
    Классификатор.Записать();
 
    КодыГрупп = Новый Массив(5);
    КодыГрупп[0] = 0;
    КодыГрупп[1] = 0;
    КодыГрупп[2] = 0;
    КодыГрупп[3] = 0;
    КодыГрупп[4] = 0;
    ПредУровень = 0;
    Пока Выборка.Следующий() Цикл
        Классификатор.Добавить();
        СтрКлассиф = ТабКлассиф.Добавить();
        Если ПредУровень > Выборка.Номн.Уровень() Тогда
            КодыГрупп[ПредУровень] = 0;
        КонецЕсли;
        КодыГрупп[Выборка.Номн.Уровень()] = КодыГрупп[Выборка.Номн.Уровень()] + 1;
        Классификатор.GROOP1 = КодыГрупп[0];
        Классификатор.GROOP2 = КодыГрупп[1];
        Классификатор.GROOP3 = КодыГрупп[2];
        Классификатор.GROOP4 = КодыГрупп[3];
        Классификатор.GROOP5 = КодыГрупп[4];
        СтрКлассиф.Groop1 = КодыГрупп[0];
        СтрКлассиф.Groop2 = КодыГрупп[1];
        СтрКлассиф.Groop3 = КодыГрупп[2];
        СтрКлассиф.Groop4 = КодыГрупп[3];
        СтрКлассиф.Groop5 = КодыГрупп[4];
        СтрКлассиф.Код = Выборка.Номн.Код;
        Классификатор.Name     = Выборка.Номн.Наименование;
        Классификатор.Записать();
        ПредУровень = Выборка.Номн.Уровень();
    КонецЦикла;
 
КонецПроцедуры //ВыгрузитьКлассификатор

3) Создала новое регламентное задание под названием ВыгрузкаВКристалл, задала расписание, указала модуль и процедуру

4) пытаюсь проверить как работает через консоль заданий. получается, что задание запускается и завершается, статус: выполнено, никаких ошибок нет, НО! дбфный файл не создался и, судя по времени начала и конца выполнения, задание выполнялось всего 2 секунды.

=============================

хм.. может, действительно, в сетевом пути дело было?
изменила код модуля на:

Код 1c:
Процедура ВыгрузитьВКристалл() Экспорт    
 
    КаталогВыгрузки = "\\crystall\pos\Test"; 
 
    ФайлКлассиф        = Новый Файл(КаталогВыгрузки+"\Classif.DBF");
    Если ФайлКлассиф.Существует() Тогда
        Отказ = Истина;
        Возврат;        
    Иначе
        ВыгрузитьКлассификатор(КаталогВыгрузки);    
    КонецЕсли;
 
КонецПроцедуры //ВыгрузитьВКристалл


и все заработало.. так я и не поняла, почему )) пробовала ведь и раньше путь прописывать таким образом..

а и еще отдельно добавила туда процедуру:

Код 1c:
Процедура ВыгрузитьКлассификатор(КаталогВыгрузки) Экспорт
 
    Классификатор = Новый XBase();
    Классификатор.Кодировка = КодировкаXBase.OEM;
    Классификатор.поля.Добавить("GROOP1", "N", 6);
    Классификатор.поля.Добавить("GROOP2", "N", 6);
    Классификатор.поля.Добавить("GROOP3", "N", 6);
    Классификатор.поля.Добавить("GROOP4", "N", 6);
    Классификатор.поля.Добавить("GROOP5", "N", 6);
    Классификатор.поля.Добавить("NAME", "S", 80);
    Классификатор.СоздатьФайл(КаталогВыгрузки +"\Classif.dbf");
 
    // Выгружаем классификатор
 
    Если Классификатор.Открыта() Тогда    
        Запрос = Новый Запрос();
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    Номенклатура.Ссылка КАК Номн
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.ЭтоГруппа = &ЭтоГруппа
        |АВТОУПОРЯДОЧИВАНИЕ";
 
        Запрос.УстановитьПараметр("ЭтоГруппа", Истина);
        РезЗапроса = Запрос.Выполнить();
        Выборка = РезЗапроса.Выбрать();
        ТабКлассиф = Новый ТаблицаЗначений;
        ТабКлассиф = РезЗапроса.Выгрузить();
        ТабКлассиф.Колонки.Добавить("Groop1");
        ТабКлассиф.Колонки.Добавить("Groop2");
        ТабКлассиф.Колонки.Добавить("Groop3");
        ТабКлассиф.Колонки.Добавить("Groop4");
        ТабКлассиф.Колонки.Добавить("Groop5");
        ТабКлассиф.Колонки.Добавить("Код");
 
        Классификатор.Добавить();
        Классификатор.GROOP1 = 0;
        Классификатор.GROOP2 = 0;
        Классификатор.GROOP3 = 0;
        Классификатор.GROOP4 = 0;
        Классификатор.GROOP5 = 0;
        Классификатор.Name     = "Классификатор товаров";
        Классификатор.Записать();
 
        КодыГрупп = Новый Массив(5);
        КодыГрупп[0] = 0;
        КодыГрупп[1] = 0;
        КодыГрупп[2] = 0;
        КодыГрупп[3] = 0;
        КодыГрупп[4] = 0;
        ПредУровень = 0;
        Пока Выборка.Следующий() Цикл
            Классификатор.Добавить();
            СтрКлассиф = ТабКлассиф.Добавить();
            Если ПредУровень > Выборка.Номн.Уровень() Тогда
                КодыГрупп[ПредУровень] = 0;
            КонецЕсли;
            КодыГрупп[Выборка.Номн.Уровень()] = КодыГрупп[Выборка.Номн.Уровень()] + 1;
            Классификатор.GROOP1 = КодыГрупп[0];
            Классификатор.GROOP2 = КодыГрупп[1];
            Классификатор.GROOP3 = КодыГрупп[2];
            Классификатор.GROOP4 = КодыГрупп[3];
            Классификатор.GROOP5 = КодыГрупп[4];
            СтрКлассиф.Groop1 = КодыГрупп[0];
            СтрКлассиф.Groop2 = КодыГрупп[1];
            СтрКлассиф.Groop3 = КодыГрупп[2];
            СтрКлассиф.Groop4 = КодыГрупп[3];
            СтрКлассиф.Groop5 = КодыГрупп[4];
            СтрКлассиф.Код = Выборка.Номн.Код;
            Классификатор.Name     = Выборка.Номн.Наименование;
            Классификатор.Записать();
            ПредУровень = Выборка.Номн.Уровень();
        КонецЦикла;
    КонецЕсли;
 
КонецПроцедуры