Много уже было про них вопросов и везде почти один совет.

Код 1c:
Процедура ОбработкаЗаданий()
    ВыполнитьОбработкуЗаданий();
КонецПроцедуры;
ПодключитьОбработчикОжидания("ОбработкаЗаданий", 5);


Но скажите как тогда работает автообмен в стандартной УТ? В режиме предприятия настраивал, сам видел как периодически запускается отправляет и получает данные. Вот бы еще в фоне все это сделать. Подскажите как?

=============================================

Вот пишу вот такой код.
Код 1c:
РЗ = РегламентныеЗадания.СоздатьРегламентноеЗадание( "ПроверкаОплат" );
РЗ.Использование = Истина;
РЗ.ИмяПользователя = ПараметрыСеанса.ТекущийПользователь;
 
ДиалогРасписания = Новый ДиалогРасписанияРегламентногоЗадания(Рз.Расписание);
    ДиалогРасписания.ОткрытьМодально();
РЗ.Расписание = ДиалогРасписания.Расписание;
РЗ.Записать();
 
Потом делаю
МассивЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания();
 
Для Сч = 0 По МассивЗаданий.Количество() - 1 Цикл
    Сообщить( МассивЗаданий.Получить( Сч ).РегламентноеЗадание );
КонецЦикла;

И моего РЗ там нет. Почему?

==============================

Вот так все заработало:

Код 1c:
Перем РЗ;
 
Процедура ПроизвестиПроверкуОплат()
    ОтключитьОбработчикОжидания( "ПроизвестиПроверкуОплат" );
    РаботаСоСправочниками.ПроверкаОплат();
    ПодключитьОбработчикОжидания( "ПроизвестиПроверкуОплат", глЗначениеПеременной("глКоличествоСекундОпросаОбмена") );
КонецПроцедуры    
 
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
 
    РЗ = РегламентныеЗадания.СоздатьРегламентноеЗадание( "ПроверкаОплат" );
    РЗ.Использование = Истина;
    РЗ.ИмяПользователя = ПараметрыСеанса.ТекущийПользователь;
 
    ДиалогРасписания = Новый ДиалогРасписанияРегламентногоЗадания(Рз.Расписание);
    ДиалогРасписания.ОткрытьМодально();
    РЗ.Расписание = ДиалогРасписания.Расписание;
    РЗ.Записать();
 
    ПодключитьОбработчикОжидания( "ПроизвестиПроверкуОплат", глЗначениеПеременной("глКоличествоСекундОпросаОбмена") );
 
КонецПроцедуры

И это не смотря на то что в Массиве фоновых заданий меня все равно нету.
Текст модуля написан во внешней обработке. Дополнительно в конфигураторе добавлено РегламентноеЗадание "ПпроверкаОплат", которое ссылается на процедуру, в этой процедуре и происходит все что необходимо для полного счастья.

=========================

В типовых конфах, специально для файловых версиях, есть константа типа "Пользователь для запуска регламентных заданий". Если в ней указать пользователя и запустить сеанс программы "под" этим пользователем, то конфа автоматически запускает обработчик ожидания. Этот обработчик "имитирует" работу планировщика заданий. Планировщик заданий проверяет расписание регламентных заданий и (если это необходимо) - запускает их. С помощью внешней обработки "Консоль регламентных заданий" с диска ИТС можно создавать рег.задания, изменять их расписание, запускать и останавливать их работу. Вопрос: автор, а что у вас не так?. Найдите три отличия