Как завершить работу определенного пользователя 1с в файловой базе ?

База файловая и вариант перевода её на клиет - серверный вариант не рассматривается.

Интересует простенький код типа :

Код 1c:
Для Каждого Соединения Из СоединенияБазы Цикл
Сервер.Disconnect(Соединение);
КонецЦикла;
Есть идеи ?

===============

У меня файловый вариант.
Я решил проблему иначе.
Использовал ПодключитьОбработчикОжидания().
Описал параметры выброса в доп. процедуре ,указав, кого надо выгонять, кого нет. Установил таймаут.
Процедуру вызвал из двух блоков.

ПередНачаломРаботыСистемы() и ПриНачалеРаботыСистемы()

Код 1c:
Процедура Отключить() Экспорт
Отключить = Константы.ЗавершениеРаботыПользователей.Получить();
Пользователь = ИмяПользователя();
Если Отключить = 1 И Пользователь <> "Администратор" Тогда
Предупреждение("Администратор информационной базы просит Вас завершить работу в системе.",5);
ИначеЕсли Отключить = 2 И Пользователь <> "Администратор" Тогда
Предупреждение("Работа системы завершается.",5);
ЗавершитьРаботуСистемы();
КонецЕсли;
 
КонецПроцедуры 
 
Процедура ПередНачаломРаботыСистемы(Отказ)
Отключить = Константы.ЗавершениеРаботыПользователей.Получить();
Пользователь = ИмяПользователя();
Если Отключить = 2 И Пользователь <> "Администратор" Тогда
Предупреждение("База заблокирована. Обратитесь к администратору.",3);
ЗавершитьРаботуСистемы();
КонецЕсли;
 
...
 
КонецПроцедуры
 
Процедура ПриНачалеРаботыСистемы()
 
ПодключитьОбработчикОжидания("Отключить",30);
....


Создал константу новую для установки режима завершения работы пользователей и форму, где собсно меняю ее. И у меня проблем нет с выбросом товарищей из базы. Есть одна существенная недоработка, но ее не так и сложно подправить. Позже опишу. Она ориентирована на НЕ лохов юзверей.
То есть могут запустить 1С, но не авторизоваться...Следовательно, пока висит окно входа у кого-то, конфу не смогу обновить. И еще одно важное примечание. Таймауты предупреждений в любом случае нужны, иначе восьмерка попросту подвисает и тогда поможет только жесткий дисконнект брутальными средствами )))

========================


"Обновить демонически"