В модуле выгрузки написан следующий код:
Код 1c:
        Товары = СоздатьОбъект("ТаблицаЗначений");            
        Товары.НоваяКолонка("Номенклатура");
        Товары.НоваяКолонка("Цена");
        Товары.НоваяКолонка("ТипЦен");
        Товары.НоваяКолонка("ЕдиницаИзмерения");
        Товары.НоваяКолонка("ПроцентСкидкиНаценки");
        Товары.НоваяКолонка("ИндексСтрокиТаблицыЦен");
        Товары.НоваяКолонка("Валюта");
        Товары.НоваяКолонка("СпособРасчетаЦены");
 
        ТипыЦен = СоздатьОбъект("ТаблицаЗначений");
        ТипыЦен.НоваяКолонка("ТипЦен");            
 
        ДатаТА = ПолучитьДатуТА();     
        ДатаНач = ?((ПустоеЗначение(ДатаНачала) = 0) И (ДатаНачала < ДатаТА), ДатаНачала,ДатаТА);        
 
        Ном=Параметры.Номенклатура;//om
 
        ТипЦ=Параметры.ТипЦен;
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса = 
            "//{{ЗАПРОС(ОтборЦен)
 
            |Период с ДатаНач по ДатаНач;
            |Номенклатура = Справочник.Цены.Владелец;
            |ТипЦен = Справочник.Цены.ТипЦен;
            |Рассчитывается = Справочник.Цены.ТипЦен.Рассчитывается;
            |БазовыйТипЦен = Справочник.Цены.ТипЦен.БазовыйТипЦен;
            |Цена = Справочник.Цены.Цена;
            |Единица = Справочник.Цены.Единица;
            |Валюта = Справочник.Цены.Валюта;
            |Процент = Справочник.Цены.Процент;
            |Функция ЦенаСумма = Сумма(Цена);
            |Группировка ТипЦен;
            |Группировка Номенклатура без групп;
            |Условие((Номенклатура.ЭтоГруппа() = 0) И (Цена <> 0)и (Номенклатура в ном) И (ТипЦен=ТипЦ));     //om
 
            |";
 
        Если Запрос.Выполнить(ТекстЗапроса) <> 0 Тогда    
               Индекс = 1;
            Номер = 0;
            Пока Запрос.Группировка(1) = 1 Цикл
                ТипыЦен.УдалитьСтроки();
                ТипыЦен.НоваяСтрока();
                ТипыЦен.ТипЦен = Запрос.ТипЦен;
                Товары.УдалитьСтроки();
                Номер = Номер + 1;
                Пока Запрос.Группировка(2) = 1 Цикл
                    Товары.НоваяСтрока();
                    Товары.Номенклатура = Запрос.Номенклатура;
                    Товары.ТипЦен = Запрос.ТипЦен;
                    Товары.Цена = Запрос.Цена;
                    Товары.ЕдиницаИзмерения = Запрос.Единица;
                    Товары.ПроцентСкидкиНаценки = Запрос.Процент;
                    Товары.ИндексСтрокиТаблицыЦен = Индекс;
                    Товары.Валюта = Запрос.Валюта;
                     Если (Запрос.Рассчитывается = 1)  Или ((Запрос.Рассчитывается = 0) И (ПустоеЗначение (Запрос.БазовыйТипЦен) = 0)) Тогда
                        Товары.СпособРасчетаЦены = "ПоПроцентнойНаценкеНаБазовыйТип";
                    КонецЕсли;
                   КонецЦикла;                     
                   ИсходящиеДанные = СоздатьОбъект("СписокЗначений");
                   ИсходящиеДанные.Установить("Номер", Номер);
                ИсходящиеДанные.Установить("Дата", ДатаНач); 
                ИсходящиеДанные.Установить("ТипыЦен",ТипыЦен); 
                ИсходящиеДанные.Установить("Комментарий", Параметры.СтрокаКомментария);
                ИсходящиеДанные.Установить("Товары", Товары);        
                ВыгрузитьПоПравилу(,, ИсходящиеДанные,, "ЦеныНоменклатуры");
                Индекс = Индекс + 1;
            КонецЦикла;    
        Иначе
            Отказ = 1;
        КонецЕсли;

В итоге в ут создаются документы "установка цен номенклатуры" согласно типам цен, заведенным в тисе, но некоторая номенклатура в тч документа двоится и записана с разными ценами. Причем при переноса только этой избранной номенклатуры все хорошо. Как такое может быть? код выложил, т.к. в 7ке плохо соображаю. может кто-нибудь поможет решить вопрос.

=======================

Все оказалось тривиально: номенклатура искалась по только по коду и заменялась при выгрузке. Какой же этой кайф - весь день ломать голову и в итоге все-таки допереть до чего-то положительного