Сделал как в статье Для просмотра ссылки необходимо зарегистрироваться (и подтвердить адрес электронной почты)
с поправкой на свою задачу.
Подключил через Сервис-> Дополнительные отчеты и обработки -> Доп. внешние печатные формы.
В докум. Счет заказа покупателя появилась соответсвующая кнопка. Но появляется ошибка
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (СсылкаНаОбъект)

В конфигураторе за это отвечает код
Код 1c:
Функция НапечататьВнешнююФорму(Ссылка, ИсточникМакета) Экспорт
 
    Перем ДополнительныеПараметры;
 
    ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ХранилищеВнешнейОбработки.Получить();
 
    // Получить дополнительные параметры внешней обработки
 
    ИсточникМакета.Свойство("ДополнительныеПараметрыОбработки", ДополнительныеПараметры);
 
    Если ДвоичныеДанные = Неопределено Тогда
        ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
    КонецЕсли;
 
    Если ДвоичныеДанные = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
 
    ТабДокумент = Неопределено;
 
    ИмяФайла = ПолучитьИмяВременногоФайла("epf");
    Попытка
        ДвоичныеДанные.Записать(ИмяФайла);
        Обработка = ВнешниеОбработки.Создать(ИмяФайла);
// здесь появляеся ошибка и перепрыгивает в конец
 
        Обработка.СсылкаНаОбъект = Ссылка;
 
        // Передать внешней обработке дополнительные параметры
 
        Если ДополнительныеПараметры <> Неопределено Тогда
 
            // Если у внешней обработки есть реквизит для дополнительных параметров, присвоить ему значение
 
            Если НЕ Обработка.Метаданные().Реквизиты.Найти("ДополнительныеПараметры") = Неопределено Тогда
                Обработка.ДополнительныеПараметры = ДополнительныеПараметры;
            КонецЕсли;
 
        КонецЕсли;
 
        ТабДокумент = Обработка.Печать();
        УдалитьФайлы(ИмяФайла);
    Исключение
        ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки(),, "Не удалось сформировать внешнюю печатную форму!");
    КонецПопытки;
 
    Возврат ТабДокумент;
 
КонецФункции

===============================

реквизит обработки не добавил СсылкаНаОбъект

прочитай справку к справочнику "Дополнительные отчеты и обработки