Добрый день!
Подскажите как программно(например обработкой) установить не активными движения какого либо документа. Возможно ли так регулировать ?

=============================

РегистрНакопленияЗапись.<Имя регистра накопления> (AccumulationRegisterRecord.<Имя регистра накопления>)
Активность (Active)
Использование:
Чтение и запись.
Описание:
Тип: Булево. Содержит флаг, определяющий влияние записи на итоги регистра накопления.
Если значение Ложь, то запись не учитывается в итогах регистра.

==================================

А как у документа убрать активность регистров ?

Попробовал

Код 1c:
Для каждого НаборЗаписей Из выбДок.ПолучитьОбъект().Движения Цикл
          НаборЗаписей.УстановитьАктивность(Ложь);
          НаборЗаписей.Записать();
    КонецЦикла;


а оно вообще затерло записи (глядя напрямую в регистр) а должно быть сереньким

=================================

непонял если имеется ввиду так

Код 1c:
Для каждого НаборЗаписей Из выбДок.ПолучитьОбъект().Движения Цикл
          //НаборЗаписей.УстановитьАктивность(Ложь);
 
          НаборЗаписей.Активность = Ложь;
          НаборЗаписей.Записать();
    КонецЦикла;

то не катит


{Документ.СторноРеализацияТоваровУслуг(145)}: Поле объекта не обнаружено (Активность)
НаборЗаписей.Активность = Ложь;

==========================

Код 1c:
Остатки = РегистрыНакопления.УчетНоменклатуры;
НаборЗаписей = Остатки.СоздатьНаборЗаписей();
Док = НаборЗаписей.Отбор.Регистратор;
Док.Установить(ВыбДок);
НаборЗаписей.Прочитать();
НаборЗаписей.УстановитьАктивность(Ложь);
НабозЗаписей.Записать(Истина);

==================================

для тех кто в танке
чтобы у тебя набор записей считался надо сделать
НаборЗаписей.Прочитать()
местная особенность такая
если нет - ты берешь пустой набор, подчиненный регистратору и его записываешь. результат прогнозируем...

=========================

Код 1c:
Для Каждого НаборЗаписей Из выбДок.ПолучитьОбъект().Движения Цикл
    НаборЗаписей.Прочитать();
    НаборЗаписей.УстановитьАктивность(Ложь);
    НаборЗаписей.Записать();
КонецЦикла;