Задача в следующем: из процедуры ПередЗаписью() документа вызывать форму нового элемента справочника на экран, после чего пользователь её заполняет, после того как он её заполняет созданный объект необходимо записать в реквизит на вызывающей форме. Делаю так:
в форме вызывающего документа

Код 1c:
Процедура  ОбработкаЗаписиНовогоОбъекта ( Объект ,  Источник )
    Если  Объект .Метаданные.ПолноеИмя() = "Справочник.ДисконтныеКарты" Тогда
        //записали новую дисконтную карту
 
        ДисконтнаяКарта    =  Объект .Ссылка;
        ТипСкидкиНаценки= Константы.ТипСкидкиДляДисконта.Получить();
        ТипСкидкиНаценкиПриИзменении(ЭлементыФормы.ТипСкидкиНаценки);
    КонецЕсли;
КонецПроцедуры
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    //определимся с дисконтом
 
    Если ДисконтнаяКарта.Пустая() Тогда
        //необходимо регистрировать дисконт
 
        ПределВыдачи    = Константы.ПределаВыдачиДисконтнойКарты.Получить();
        ИтогЧека        = ЭтотОбъект.Товары.Итог("Сумма");
        Если ПределВыдачи <= ИтогЧека Тогда
            СпрДисконт    = Справочники.ДисконтныеКарты;
            КлючУникальности    = Новый УникальныйИдентификатор;
            ФормаНового    = СпрДисконт.ПолучитьФормуНовогоЭлемента(,,КлючУникальности);
            ФормаНового.ВладелецФормы    = ЭтаФорма;
            ФормаНового.ОткрытьМодально();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

в форме элемента справочника "ДисконтныеКарты"
Код 1c:
Процедура ПослеЗаписи()
    ОповеститьОЗаписиНовогоОбъекта(ЭтотОбъект);
КонецПроцедуры

Но ОповеститьОЗаписиНовогоОбъекта срабатывает, однако в родительсокой форме ОбработкаЗаписиНовогоОбъекта не вызывается. Почему?
П.С. Ногами не бить, я вообще семёрошник.

==========================================

Цитата из СП:
"Возникает при записи объекта в одной из подчиненных форм или при вызове в одной из подчиненных форм метода ОповеститьОЗаписиНовогоОбъекта(). "

поэтому убери это:

Код 1c:
Процедура ПослеЗаписи()
    ОповеститьОЗаписиНовогоОбъекта(ЭтотОбъект);
КонецПроцедуры
 
а здесь проверь детально:
Процедура  ОбработкаЗаписиНовогоОбъекта ( Объект ,  Источник )
    Сообщить("есть запись в форме "+  Источник .Заголовок+" новый элемент типа "+ТипЗнч( Объект )+" : "+ Объект .Метаданные.ПолноеИмя());
    Если  Объект .Метаданные.ПолноеИмя() = "Справочник.ДисконтныеКарты" Тогда
        //записали новую дисконтную карту
 
 
        ДисконтнаяКарта    =  Объект .Ссылка;
        ТипСкидкиНаценки= Константы.ТипСкидкиДляДисконта.Получить();
        ТипСкидкиНаценкиПриИзменении(ЭлементыФормы.ТипСкидкиНаценки);
    КонецЕсли;
КонецПроцедуры

==============================================

делал так

Код 1c:
            КлючУникальности    = Новый УникальныйИдентификатор;
            ФормаНового    = СпрДисконт.ПолучитьФормуНовогоЭлемента(,ЭтаФорма,КлючУникальности);
            ФормаНового.ОткрытьМодально();
не помогает.

========================

В самой форме в свойствах событие " ОбработкаЗаписиНовогоОбъекта " установлено?

============================

Нет. А на какое событие навешивать эту процедуру?
на Обработка оповещения?
Так она вроде срабатывает только при Оповестить()
или на Обработка выбора?
Так она вроде возникает при выборе объекта в одной из подчиненных форм. Но это же не выбор объекта, а запись объекта?

===========================

А, кажись нашёл, вешать надо на событие "при записи нового объекта". Сейчас попробую.
точно, работает, спасибо Neco и всем остальным
совсем забыл что в восьмёрке нет имён предопределённых процедур.