Вот собственно файл, необходимо получить значение тега UID

Код 1c:
<SOAP-ENV:Envelope xmlns:SOAP-ENV="SOAP-ENV">
- <SOAP-ENV:Header>
  <RID>{BA14EF4A-6A39-42BE-AC1A-C5D8EEFE97DF}</RID> 
  </SOAP-ENV:Header>
- <SOAP-ENV:Body>
- <GetAuthorizateResponse>
  <UID>{D9265465-B4EE-415B-A6D3-7BB4095D6BE2}</UID> 
  </GetAuthorizateResponse>
  </SOAP-ENV:Body>
  </SOAP-ENV:Envelope>
 
Анализатор        =    СоздатьОбъект("AddIn.XMLParser");
 
    XML_Документ    =    Анализатор.СоздатьДокумент();
    XML_Документ.ЗагрузитьИзСтроки(ReceivedXML);// собственно то, что выше
 
    Сообщить(XML_Документ.ЭлементДокумента.Наименование);
    КорневойЭлемент = XML_Документ.ЭлементДокумента;
    Боди = КорневойЭлемент.ВыбратьУзел("Body");
    ВторойУровень = Боди.ВыбратьУзел("GetAuthorizateResponse");// Вот здесь ругается
 
    УИД = ВторойУровень.ПолучитьАтрибут("UID");
    Сообщить("УИД "+УИД);

=====================================

Код 1c:
нализатор        =    СоздатьОбъект("AddIn.XMLParser");
 
    XML_Документ    =    Анализатор.СоздатьДокумент();
    XML_Документ.ЗагрузитьИзСтроки(ReceivedXML);// собственно то, что выше 
 
   // Сообщить(XML_Документ.ЭлементДокумента.Наименование); 
 
    КорневойЭлемент = XML_Документ.ВыбратьУзел("SOAP-ENV:Envelope...");//не вкурил имя тега 
 //   Боди = КорневойЭлемент.ВыбратьУзел("Body"); 
    ВторойУровень = КорневойЭлемент.ВыбратьУзел("GetAuthorizateResponse");// Вот здесь ругается 
 
    УИД = ВторойУровень.ПолучитьАтрибут("UID");
    Сообщить("УИД "+УИД);

=======================================

Код 1c:
XML_Документ    =    Анализатор.  СоздатьПоследовательноСчитываемыйДокумент ();
    XML_Документ.СвязатьСоСтрокой(ReceivedXML);
 
    ТипТега = XML_Документ.Спуститься();
    УзелБоди = XML_Документ.ВыбратьУзел
    ТипТега = XML_Документ.Спуститься();
    Пока ТипТега <> 4 Цикл        //    пока не достигнут конец файла
 
        Если ТипТега <> 1 Тогда
            ТипТега = XML_Документ.Следующий();
            Продолжить;
        КонецЕсли;                //    пропускаем концы уровней и инструкции
 
 
        ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
        Сообщить(ИмяТега);        
        Если Нрег(СокрЛП(ИмяТега)) = "body" Тогда
            XML_Документ.Спуститься();
            ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
            Сообщить(ИмяТега);
            XML_Документ.Спуститься();
            ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
            Сообщить(ИмяТега);
        КонецЕсли;    
        ТипТега = XML_Документ.Следующий();
    КонецЦикла;
 
    Сообщить(УИД);

===========================================

я бы сделал так

Код 1c:
ВторойУровень = КорневойЭлемент.ВыбратьУзел("GetAuthorizateResponse");
Для у = 1 По ВторойУровень.КоличествоПодчиненных() Цикл
     ПП = ВторойУровень.ПолучитьПодчиненныйПоНомеру(у)
     ИмяУИДа = ПП.ПолучитьАтрибут("UID");

=================================

Вот так работает, но через одно место, выдает <UID>{D9265465-B4EE-415B-A6D3-7BB4095D6BE2}</UID>

Код 1c:
XML_Документ    =    Анализатор. СоздатьПоследовательноСчитываемыйДокумент ();
    XML_Документ.СвязатьСоСтрокой(ReceivedXML);
 
    ТипТега = XML_Документ.Спуститься();
    //УзелБоди = XML_Документ.ВыбратьУзел
 
    ТипТега = XML_Документ.Спуститься();
    Пока ТипТега <> 4 Цикл        //    пока не достигнут конец файла
 
        Если ТипТега <> 1 Тогда
            ТипТега = XML_Документ.Следующий();
            Продолжить;
        КонецЕсли;                //    пропускаем концы уровней и инструкции
 
 
        ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
        Сообщить(ИмяТега);        
        Если Нрег(СокрЛП(ИмяТега)) = "body" Тогда
            XML_Документ.Спуститься();
            ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
            Сообщить(ИмяТега);
            XML_Документ.Спуститься();
            ИмяТега = XML_Документ.СвойстваТекущегоУзла.Имя;
            Если Нрег(СокрЛП(ИмяТега)) = "uid" Тогда
                ДанныеТега = XML_Документ.ТекущийЭлементВВидеСтроки();
                Сообщить(ДанныеТега);
            КонецЕсли;
            Сообщить(ИмяТега);
        КонецЕсли;    
        ТипТега = XML_Документ.Следующий();
    КонецЦикла;

=================================

спс, ладно, пойду домой, легче строку парсить, а то что-то какой-то геммор