Как получить строки табличного поля, отобранные отбором. Автор статьи: Гений 1С | Редакторы:


Ключевые слова: отбор,табличное поле


Как то мне понадобилось получить список строк табличного поля, которые отобраны пользователем с помощью отбора, чтобы потом их удалить. Мне предлагали построить эквивалентный запрос, но я посчитал это слишком сложным.
В итоге родилось простое решение. Оно основано на том, чтобы перебрать все строки источника данных табличного поля и по очереди текущей строкой устанавливать текущую строку источника данных. Если строка в отборе, то она установится как текущая, иначе не установится. Вот и все. Смотрите код.

Работает по идее не только для регистров, но и для прочих табличных полей.

Код 1c:
   //Задача - удалить все строки из табличного поля ТаблицаРегистра, которые отобраны отбором
     //ТаблицаРегистра - табличное поле формы
     ТаблицаРегистра=ЭлементыФормы[ТаблицаРегистраИмя];
    //Т - данные элемента формы ТаблицаРегистра, имеют тип, например "РегистрНакопленияНаборЗаписей.ЗатратыБухгалтерскийУчет"
     Т=Неопределено; 
    Выполнить("Т="+ТаблицаРегистра.Данные);
 
    //Список строк, которые удаляем
     СтрокиКУдалению=Новый Массив();
 
    //Перебираем все строки источника данных
     Для Каждого Стр ИЗ Т Цикл
        //Пробуем у табличного поля поставить в качестве текущей строки текущую строку источника данных
         //Такое присваивание работает как ни странно даже для типа  РегистрНакопленияЗапись.ЗатратыБухгалтерскийУчет
         //Т.е. даже для записей из набора записей работает
         ТаблицаРегистра.ТекущаяСтрока=Стр;
 
        //Если строка попадает в отбор, то текущая строка устанавливается, иначе остается прежней
         Если ТаблицаРегистра.ТекущаяСтрока=Стр Тогда
            СтрокиКУдалению.Добавить(Стр); //Здесь логика алгоритма - то, что в отборе, нужно удалить
         КонецЕсли;
    КонецЦикла;
    //Перебираем 
     Для Каждого Стр ИЗ СтрокиКУдалению Цикл
        Т.Удалить(Стр); //Удаляем строку
     КонецЦикла;





Другой вариант, не мой, используется ПостроительЗапроса:

Код 1c:
ОтборСтрок = <ТабличнаяЧастьИсточник.ОтборСтрок>; 
ПостроительЗапроса = Новый ПостроительЗапроса; 
ПостроительЗапроса.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТабличнаяЧастьИсточник); 
 
// Добавляются необходимые отборы, такие же как в отборы в табличной части. 
Для Каждого ЭлементОтбора Из ОтборСтрок Цикл 
    Если ЭлементОтбора.Использование Тогда 
        НовыйОтбор = ПостроительЗапроса.Отбор.Добавить(ЭлементОтбора.Имя); 
        НовыйОтбор.Использование = Истина; 
        НовыйОтбор.ВидСравнения = ЭлементОтбора.ВидСравнения; // нужный вид сравнения 
        НовыйОтбор.ЗначениеС = ЭлементОтбора.ЗначениеС; 
        НовыйОтбор.ЗначениеПо = ЭлементОтбора.ЗначениеПо; 
        НовыйОтбор.Значение = ЭлементОтбора.Значение; 
    КонецЕсли; 
КонецЦикла; 
 
Результат = ПостроительЗапроса.Результат; // отобранные строки типа РезультатЗапроса