Библиотека sb_lion.dll

====================================

упс... так вот... операционная система vista, но и под xp таже проблема...
1)права админа.
2)вызывается из того же места, что и зарегистрирована...
3)поставила vkloader... собственно возможно я неправильно заполнила файлег .clsid (Addin.sb_lion = {E8E1A2FA-7953-41E5-B4EC-8EDBE84ED99E}), только других идей уже просто нет.
меня немного смущаит, что при регистрации библиотеки через regsvr32 не создается раздела с таким названием Addin.sb_lion.
может кто сталкивался или просто есть какие-нить идеи?
ЗЫ: sb_lion.dll библиотека для сбербанковского терминала с поддержкой на одном терминале 2-х юр лиц. (тех поддержка банка по 1с не консультирует, все их тестовые программки работают)

==========================================

Первый раз зайди в Винду с правами Администратора и Библиотеку зарегистрируй командой resvr32

=================================================

это написано в каждой теме по внешним компонентам... и было проверено чуть ли не в первую очередь...

============================================

Скорее всего интерфейса в ней правда нет.

===========================================

что значит в ней нет интерфейса? как это проверить? и как в этом случае с ней работать через 1с?

===============================================

именно это я и пытаюсь сделать в чистой конфе
перем СБКарт Экспорт;

Код 1c:
Процедура ПриНачалеРаботыСистемы()
 
    имяф = "D:\Doc\1c\myTest\sb_lion.dll";
 
    Если ФС.СуществуетФайл(имяф)=0 Тогда
        Сообщить("Не найден файл внешней компоненты "+имяф);
        Возврат;
    КонецЕсли;    
 
    Если ЗагрузитьВнешнююКомпоненту(имяф)=0 Тогда
        Сообщить("Ошибка при загрузке внешней компоненты "+имяф);
        Возврат;
    Иначе
        Состояние("Все нормально, все идет нормально!!");
    КонецЕсли;    
 
    Попытка
        СБКарт = СоздатьОбъект("sb_lion.ISbCard");
    Исключение
        Сообщить("Не удается создать объект AddIn.sb_lion... !!");
        Сообщить("Зайдите в Windows под правами локального администратора и повторите попытку.");
        Возврат;
    КонецПопытки;
 
    ОткрытьФорму("Отчет.Проверка");
КонецПроцедуры

в результате:

Ошибка при создании объекта из компоненты D:\Doc\1c\myTest\sb_lion.dll (отсутствует интерфейс IInitDone)
Ошибка при загрузке внешней компоненты D:\Doc\1c\myTest\sb_lion.dll

=============================================

Вот правильный код (спасиб H A D G E H O G s)
Код 1c:
    Если ФС.СуществуетФайл(имяф)=0 Тогда
        Сообщить("Не найден файл внешней компоненты "+имяф);
        Возврат;
    КонецЕсли;    
 
    Попытка
        СБКарт = СоздатьОбъект("Sb_lion.SbCard");
    Исключение
        Сообщить("Не удается создать объект AddIn.sb_lion... !!");
        Сообщить("Зайдите в Windows под правами локального администратора и повторите попытку.");
        Возврат;
    КонецПопытки;


Т.е. было две ошибки:
1. ЗагрузитьВнешнююКомпоненту не нужно (раз сом-сервер)
2. надо писать Sb_lion.SbCard, а не Sb_lion.iSbCard

======

паника... у меня все прекрасно работает, если всё файло для терминала валяется в каталоге базы, но надо чтобы оно валялось в отдельной папке (база сетевая, 2 банковских терминала). Если фсе фигачу по пути C:\Program Files\Штрих-М\Sberbank\ при использовании методов sb_lion (к примеру, close_day("","")) пишет ошибка загрузки gate.dll
Т_Т