Вот из "Простых примеров разработки"

Код 1c:
 
Текст = Новый ТекстовыйДокумент; 
Текст.Прочитать("c:\temp\text.txt"); 
 
Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл 
 Стр = Текст.ПолучитьСтроку(НомерСтроки); 
 Позиция = Найти(Стр, ";"); 
 Код = Сред(Стр, 1, Позиция-1); 
 Наименование = Сред(Стр, Позиция + 1); 
 
 Сообщить(Код + "-" + Наименование); 
КонецЦикла;

Код 1c:
    Текст = Новый ТекстовыйДокумент; 
    Текст.Прочитать(ПолноеИмяФайла); 
 
    Для Номер = 1 По Текст.КоличествоСтрок() Цикл 
        Строка = Текст.ПолучитьСтроку(Номер);
        Реквизиты = СтрЗаменить(Строка,";",Символы.ПС);
        Массив = Новый Массив();
        Для Индекс = 1 По СтрЧислоСтрок(Реквизиты) Цикл
            Массив.Добавить(СтрПолучитьСтроку(Реквизиты,Индекс));
        КонецЦикла;
        ...
        РеквизитХ = Массив[0];
        РеквизитY = Массив[1];
        ...
    КонецЦикла;