Для удобного просмотра сайта рекомендуется использовать Google Chrome.


+ Ответить в теме
Показано с 1 по 2 из 2

Тема: Схема компоновки данных

  1. #1
    Junior Member Аватар для YuriKitaev
    Регистрация
    18.07.2015
    Сообщений
    2
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию Схема компоновки данных

    Как изменить заголовок Доступного Поля Группировки настройки отчета?
    Пробовал:
    ОтчетОбъект=РеквизитФормыВЗначение("Отчет");
    Схема=ОтчетОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Поля=Отчет.КомпоновщикНастроек.Настройки.ДоступныеПоляГруппировок.Элементы;
    ПолеПоиска = Новый ПолеКомпоновкиДанных("Субконто1");
    Для каждого П Из Поля Цикл
    Если П.Поле=ПолеПоиска Тогда
    П.Заголовок="Основные соедства";
    КонецЕсли;
    КонецЦикла;
    Сообщение:
    {Форма.ФормаОтчета.Форма(27)}: Поле объекта недоступно для записи (Заголовок)
    П.Заголовок="Основные соедства";

  2. #2
    Junior Member Аватар для YuriKitaev
    Регистрация
    18.07.2015
    Сообщений
    2
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Можно воспользоваться событием «ПриКомпоновкеРезультата», где можно изменять поля группировок непосредственно перед компоновкой макета.
    Пример изменения заголовка для поля "Субконто1":
    Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    Поля=СхемаКомпоновкиДанных.НаборыДанных.НаборДанных1.Поля;
    Для каждого П Из Поля Цикл
    Если П.Поле="Субконто1" Тогда
    П.Заголовок="Основные соедства";
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

+ Ответить в теме

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Похожие темы

  1. Система компоновки данных
    от Verojer в разделе 8.2/8.3
    Ответов: 16
    Последнее сообщение: 21.02.2012, 21:20
  2. Система компоновки данных
    от Verojer в разделе 8.2/8.3
    Ответов: 34
    Последнее сообщение: 21.02.2012, 18:11
  3. Система компоновки данных
    от Verojer в разделе 8.2/8.3
    Ответов: 684
    Последнее сообщение: 13.02.2012, 16:49
  4. Схема компоновки данных
    от Verojer в разделе 8.2/8.3
    Ответов: 245
    Последнее сообщение: 04.02.2012, 00:16
  5. Схема компоновки данных: макеты
    от maverick в разделе 8.0/8.1
    Ответов: 0
    Последнее сообщение: 25.11.2010, 17:22

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения


Навигация по сайту:
, 1c, 1с 8.2, 1с 8.3, Скачать 1с, 1с бухгалтерия, 1с предприятие, Программа 1с,
1с торговля, 1с управление, 1с зарплата, Обновление 1с, Миста, Программирование 1с,

Положение об ответственности
Связь с администрацией erpsolution.ru@yandex.ru