Вопрос:
Подскажите пож-та почему не срабатывает такая ert-шка (хочу почистить справочник):
//Очистка справочника "Организации"
Процедура УдалениеСп()
Спр=СоздатьОбъект("Справочник.Организации");
Спр.ВыбратьЭлементы();

Пока Спр.ПолучитьЭлемент()>0 Цикл

Спр.Удалить(1);
КонецЦикла;
КонецПроцедуры;
//---------------------------------------------------

---------------
Ответ: Кроме того, что такой способ опасен с точки зрения ссылочной целостности базы данных, еще и работает он некорректно:
ВыбратьЭлементы - строит индексы для выборки информации. Во-время первой итерации удаляется первый элемент справочника, а индексы выборки не меняются.
Разумно использовать транзакцию. При этом реальное удаление (пометка на удаление) всех элементов произойдет только по команде ЗафиксироватьТранзакцию(). На время транзакции справочник блокируется.
Спр = СоздатьОбъект("Справочник.Организации ");
НачатьТранзакцию();
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
...... Спр.Удалить(1);
КонецЦикла;
ЗафиксироватьТранзакцию();


Вопрос:
почему не удается удалить поступление за 2008г, идут ссылки на 2007г?
Ответ: Вопрос не совсем понятен. «Ссылки» обычно «идут» не на год, а на конкретные объекты базы данных. В данном случае советую воспользоваться механизмом поиск ссылок на объект: Операции – поиск ссылок на объекты…
В верхнем окне добавляем объект для поиска (в Вашем случает документ Поступление ТМЦ) и нажимаем кнопку «Найти».
В нижнем окне появляются все объекты, которые ссылаются на выбранный документ.
Механизм сохранения ссылочной целостности предполагает, что «для того, чтобы удалить помеченный на удаление объект из базы данных 1С:Предприятия необходимо, чтобы все объекты, у которых есть ссылки на данных объект были также помечены на удаление» - так что выясните, - что за объекты ссылаются на Ваш документ и также пометьте их.



Вопрос:
При загрузке изменений с основной базы в распределенную пишет "Невосстановимая ошибка базы данных, код 4, таблица CS195, общая ошибка ввода-вывода"
Ответ: Скорее всего произошло повреждение структуры таблицы CS195. Сначала попробуйте провести стандартную процедуру Тестирования и исправления информационной базы, затем стоит использовать специализированные методы ремонта DBF файлов – использование DBF редактора, например Visual Fox PRO, или, если таблица не существенна, - воспользоваться свойством автовосстановления файла системой после удаления (копирования в безопасное место) поврежденного файла.


Вопрос:
Где найти описание конфигурации 1С:Финансовое планирование?
Ответ: Описание можно найти на официальном сайте фирмы 1С Для просмотра ссылки необходимо зарегистрироваться (и подтвердить адрес электронной почты) -
решение предназначено для бюджетирования и анализа финансовых потоков и структуры средств предприятия. В настоящий момент фирма 1С сняла с продажи данный программный продукт. Его приемниками являются программы 1С:Управляющий 2.0 Для просмотра ссылки необходимо зарегистрироваться (и подтвердить адрес электронной почты) и программный комплекс Управление производственным предприятием Для просмотра ссылки необходимо зарегистрироваться (и подтвердить адрес электронной почты)



Вопрос:
Как просмотреть историю созданияизменения документа в 1С:Предприятие 7.7?
Ответ: Воспользуйтесь пунктом меню Сервис - Монитор пользователей - Журнал регистрации. Инструмент предназначен для просмотра журнала регистрации событий в программе 1С:Предприятие 7.7. Для просмотра информации по конкретному объекту зайдите на закладку "Объекты", поставьте галку "Отбор событий по объекту", выберите тип объекта (например, Документ Начисление заработной платы) и объект - конкретный документ из журнала.
Нажмите кнопку "ОК"


Вопрос:
Как сделать, чтобы нумерация документа в 1с начиналась по-новой с начала года?
Ответ: Подобный механизм устанавливается в режиме конфигурирования. Внимание! Если Вы не уверены, что сможете правильно и безопасно для базы проделать все действия, то обратитесь к специалистам. Обязательно сделайте резервную копию базы данных! В Конфигураторе 1С:предприятия 7.7 выбираем документ, кликаем дважды на него мышью, затем в поле "Периодичность" ставим "В пределах года". Сохраняем конфигурацию.