Для удобного просмотра сайта рекомендуется использовать Google Chrome.


Закрытая тема
Страница 1 из 16 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 ... Следующая ПоследняяПоследняя
Показано с 1 по 10 из 154

Тема: Справочники

  1. #1
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию Справочники

    Справочники

    Справочники
    Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа "Справочник". Обычно справочниками являются списки материалов, товаров, организаций, валют, сотрудников и др. Название и структура каждого конкретного справочника определяется при его создании в конфигураторе. На этапе конфигурирования можно описать, какими свойствами обладает каждый конкретный справочник. К настраиваемым свойствам относятся, например, длина и тип кода, количество уровней, поддержка уникальности кодов, набор реквизитов справочника. Помимо кода и наименования, механизм работы со справочниками позволяет создавать набор реквизитов для хранения любой дополнительной информации об элементе справочника.Пример:

    // Пример создания нового элемента
    НовыйОбъект = Справочники.Валюты.СоздатьЭлемент();
    НовыйОбъект.Код = "840";
    НовыйОбъект.Наименование = "USD";
    НовыйОбъект.ПолноеНаименование = "Доллары США";
    НовыйОбъект.Записать();

    // Пример обработки выборки справочника
    Номенклатура = Справочники.Номенклатура;
    Отбор = Новый Структура();
    Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();
    Отбор.Вставить("ТипНоменклатуры",Пусто);
    Выборка = Номенклатура.Выбрать(,,Отбор, "Наименование Убыв");
    НачатьТранзакцию();
    Пока
    Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
    Объект.Записать();
    КонецЦикла
    ;
    ЗафиксироватьТранзакцию();


  2. #2
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    СправочникиМенеджер (CatalogsManager)

    СправочникиМенеджер (CatalogsManager)
    Элементы коллекции:

    СправочникМенеджер
    Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются менеджеры справочников.
    Возможно обращение к менеджеру справочника посредством оператора [...]. В качестве аргумента передается имя справочника, как оно задано в конфигурации.
    Свойства:

    <Имя справочника> (<Catalog name>)
    Методы:

    ТипВсеСсылки (AllRefsType)
    Описание:

    Предназначен для управления справочниками и предоставляет доступ к значениям типа СправочникМенеджер.. Доступ к объекту осуществляется через свойство глобального контекста Справочники.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.
    Возможен обмен с сервером.Пример:

    Для каждого Справочник из Метаданные.Справочники Цикл
    ИмяСправочника = Справочник.Имя;
    МенеджерСправочника = Справочники[ИмяСправочника];
    ВыборкаСправочника = МенеджерСправочника.Выбрать();
    Если
    ВыборкаСправочника.Следующий() Тогда
    Текст = "ru = ""В информационной базе есть заполненные справочники!"""
    + "; en = ""There are filled catalogs in the infobas!""";
    Предупреждение(НСтр(Текст));
    Возврат
    ;
    КонецЕсли
    ;
    КонецЦикла
    ;


  3. #3
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Свойста:
    СправочникиМенеджер.<Имя справочника> (CatalogsManager.<Catalog name>)


    СправочникиМенеджер (CatalogsManager)
    <Имя справочника> (<Catalog name>)
    Использование:

    Только чтение.Описание:

    Тип: СправочникМенеджер.
    Набор свойств содержит менеджеры отдельных справочников. Доступ к менеджеру осуществляется по имени, как оно задано в конфигураторе.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.

  4. #4
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Методы:
    СправочникиМенеджер.ТипВсеСсылки (CatalogsManager.AllRefsType)


    СправочникиМенеджер (CatalogsManager)
    ТипВсеСсылки (AllRefsType)
    Синтаксис:

    ТипВсеСсылки()Возвращаемое значение:

    Тип: ОписаниеТипов.
    Описание:

    Получает описание типов, содержащее типы ссылок справочников.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.Пример:

    // Получение списка видов сравнения по типу
    Список = Новый СписокЗначений;
    Список.Добавить(ВидСравнения.Равно);
    Список.Добавить(ВидСравнения.НеРавно);
    Список.Добавить(ВидСравнения.ВСписке);
    Список.Добавить(ВидСравнения.НеВСписке);
    // МассивТипов - массив возможных типов
    Для Индекс = 0 по МассивТипов.Количество() - 1 Цикл
    Если Справочники.ТипВсеСсылки().СодержитТип(МассивТипов[Индекс]) Тогда
    Если Метаданные.НайтиПоТипу(МассивТипов[Индекс]).Иерархический Тогда
    Список.Добавить(ВидСравнения.ВСпискеПоИерархии);
    Список.Добавить(ВидСравнения.НеВСпискеПоИерархии);
    Прервать
    ;
    КонецЕсли
    ;
    КонецЕсли
    ;
    КонецЦикла
    ;


  5. #5
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)

    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    Свойства:

    <Имя предопределенного элемента справочника> (<Name of a predefined catalog item>)
    Методы:

    Выбрать (Select)
    ВыбратьИерархически (SelectHierarchically)
    НайтиПоКоду (FindByCode)
    НайтиПоНаименованию (FindByDescription)
    НайтиПоРеквизиту (FindByAttribute)
    ПолучитьДанныеВыбора (GetChoiceData)
    ПолучитьИмяПредопределенного (GetPredefinedItemName)
    ПолучитьМакет (GetTemplate)
    ПолучитьСсылку (GetRef)
    ПолучитьФорму (GetForm)
    ПолучитьФормуВыбора (GetChoiceForm)
    ПолучитьФормуВыбораГруппы (GetFolderChoiceForm)
    ПолучитьФормуНовогоЭлемента (GetNewItemForm)
    ПолучитьФормуНовойГруппы (GetNewFolderForm)
    ПолучитьФормуСписка (GetListForm)
    ПустаяСсылка (EmptyRef)
    СоздатьГруппу (CreateFolder)
    СоздатьЭлемент (CreateItem)
    События:

    ОбработкаПолученияДанныхВыбора (ChoiceDataGetProcessing)
    ОбработкаПолученияФормы (FormGetProcessing)
    Описание:

    Предназначен для управления справочником, как объектом конфигурации. С помощью этого объекта осуществляется поиск элементов, создание новых элементов и групп, работа с формами и макетами справочника. Доступ к объекту осуществляется через свойства объекта СправочникиМенеджер. Полное имя типа объекта определяется с учетом имени справочника конфигурации. Например, для справочника "Номенклатура" имя типа будет выглядеть СправочникМенеджер.Номенклатура.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.
    Возможен обмен с сервером.

  6. #6
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Свойства:
    СправочникМенеджер.<Имя справочника>.<Имя предопределенного элемента справочника> (CatalogManager.<Имя справочника>.<Name of a predefined catalog item>)


    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    <Имя предопределенного элемента справочника> (<Name of a predefined catalog item>)
    Использование:

    Только чтение.Описание:

    Тип: СправочникСсылка.
    Содержит ссылки на предопределенный объект справочников. Доступ к значению осуществляется по имени, как они заданы в конфигураторе. Имена имеют только предопределенные элементы справочников. Количество таких свойств задается списком предопределенных элементов справочника.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.

  7. #7
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Методы:
    СправочникМенеджер.<Имя справочника>.Выбрать (CatalogManager.<Имя справочника>.Select)


    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    Выбрать (Select)
    Синтаксис:

    Выбрать(<Родитель>, <Владелец>, <Отбор>, <Порядок>)Параметры:

    <Родитель> (необязательный)

    Тип: СправочникСсылка.
    Отбор по родителю. Имеет смысл только для многоуровневых справочников. Если параметр не задан, то отбор по родителю не производится. Чтобы отобрать элементы верхнего уровня, нужно в качестве данного параметра указать пустую ссылку на элемент справочника.<Владелец> (необязательный)

    Тип: СправочникСсылка.
    Отбор по владельцу. Имеет смысл только для подчиненных справочников. Если параметр не задан, то отбор по владельцу не производится.<Отбор> (необязательный)

    Тип: Структура.
    Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться только поля "Код", "Наименование" и реквизиты справочника, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.".
    Важно! Структура может содержать только один элемент.
    Если параметр не указан, то отбор не используется.<Порядок> (необязательный)

    Тип: Строка.
    Строка с именем реквизита справочника, определяющая упорядочивание элементов в выборке. Может быть указано "Код", "Наименование" или имя одного из реквизитов примитивного типа (Число, Строка, Дата, Булево), для которого установлен признак "Индексирование" в значение "Индексировать" или в "Индексировать с дополнительным упорядочиванием" в конфигураторе. После имени реквизита через пробел может быть указано направление сортировки. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию; "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию сортировка производится по возрастанию. Если параметр не указан, то порядок определяется основным представлением справочника.
    Значение по умолчанию: Пустая строкаВозвращаемое значение:

    Тип: СправочникВыборка.
    Описание:

    Формирует выборку элементов справочника по заданным условиям.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.Пример:

    Номенклатура = Справочники.Номенклатура;
    Отбор = Новый Структура("ТипНоменклатуры");
    Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();
    Отбор.ТипНоменклатуры = Пусто;
    Выборка = Номенклатура.Выбрать(,,Отбор, "Наименование Убыв");
    Пока
    Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
    Попытка
    Объект.Записать();
    Исключение
    Текст = "ru = ""Невозможно записать объект"";"
    + " en = ""Can't write object""";
    Предупреждение(НСтр(Текст)+" """ + Объект + """
    |"
    + ОписаниеОшибки(),60);
    КонецПопытки
    ;
    КонецЦикла
    ;


  8. #8
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    СправочникМенеджер.<Имя справочника>.ВыбратьИерархически (CatalogManager.<Имя справочника>.SelectHierarchically)

    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    ВыбратьИерархически (SelectHierarchically)
    Синтаксис:

    ВыбратьИерархически(<Родитель>, <Владелец>, <Отбор>, <Порядок>)Параметры:

    <Родитель> (необязательный)

    Тип: СправочникСсылка.
    Отбор по родителю. Имеет смысл только для многоуровневых справочников. Если параметр не задан, то отбор по родителю не производится.<Владелец> (необязательный)

    Тип: СправочникСсылка.
    Отбор по владельцу. Имеет смысл только для подчиненных справочников. Если параметр не задан, то отбор по владельцу не производится.<Отбор> (необязательный)

    Тип: Структура.
    Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. Могут задаваться только "Код", "Наименование" и реквизиты справочника, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.".
    Важно! Структура может содержать только один элемент.
    Если параметр не указан, то отбор не используется.<Порядок> (необязательный)

    Тип: Строка.
    Строка с именем реквизита справочника, определяющая упорядочивание элементов в выборке. Может быть указано "Код", "Наименование" или имя одного из реквизитов примитивного типа (Число, Строка, Дата, Булево), для которого установлен признак "Индексирование" в значение "Индексировать" или "Индексировать с дополнительным упорядочиванием" в конфигураторе. После имени реквизита через пробел может быть указано направление сортировки. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию; "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию сортировка производится по возрастанию. Если параметр не указан, то порядок определяется основным представлением справочника.
    Значение по умолчанию: Пустая строкаВозвращаемое значение:

    Тип: СправочникВыборка.
    Описание:

    Формирует иерархическую выборку элементов справочника по заданным условиям. При иерархической выборке для каждого элемента сначала выбираются элементы, для которых он является родителем, а затем уже выбираются элементы следующего уровня.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.Пример:

    Товары = Справочники.Номенклатура;
    ВыборкаСправочника = Товары.ВыбратьИерархически();


  9. #9
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    СправочникМенеджер.<Имя справочника>.НайтиПоКоду (CatalogManager.<Имя справочника>.FindByCode)

    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    НайтиПоКоду (FindByCode)
    Синтаксис:

    НайтиПоКоду(<Код>, <ПоискПоПолномуКоду>, <Родитель>, <Владелец>)Параметры:

    <Код> (обязательный)

    Тип: Число; Строка.
    Искомый код.
    Строка или число в зависимости от настроек справочника в конфигураторе.<ПоискПоПолномуКоду> (необязательный)

    Тип: Булево.
    Определяет режим поиска по полному коду. Истина - искомый код следует задавать в виде строки, состоящей из последовательности кодов по уровням справочника, разделенных символом "/".
    Значение по умолчанию: Ложь<Родитель> (необязательный)

    Тип: СправочникСсылка.
    Родитель, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.<Владелец> (необязательный)

    Тип: СправочникСсылка.
    Владелец, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.Возвращаемое значение:

    Тип: СправочникСсылка.; Неопределено.
    Если не существует ни одного элемента с требуемым кодом, то будет возвращена пустая ссылка.
    Если для справочника код не задан (длина = 0), то будет возвращено Неопределено.Описание:

    Осуществляет поиск элемента по его коду.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.Пример:

    СтрокаКода = "840";
    Валюты = Справочники.Валюты;
    НайденнаяСсылка = Валюты.НайтиПоКоду(СтрокаКода);
    Если
    НайденнаяСсылка = Валюты.ПустаяСсылка() Тогда
    Сообщить("Валюты """ + СтрокаКода + """ еще нет");
    КонецЕсли
    ;


  10. #10
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    СправочникМенеджер.<Имя справочника>.НайтиПоНаименованию (CatalogManager.<Имя справочника>.FindByDescription)

    СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
    НайтиПоНаименованию (FindByDescription)
    Синтаксис:

    НайтиПоНаименованию(<Наименование>, <ТочноеСоответствие>, <Родитель>, <Владелец>)Параметры:

    <Наименование> (обязательный)

    Тип: Строка.
    Строка, содержащая искомое наименование.<ТочноеСоответствие> (необязательный)

    Тип: Булево.
    Определяет режим поиска по полному соответствию.
    Поиск будет успешным, если строка поиска: в случае значения параметра Ложь - будет соответствовать левой части наименования; в случае значения параметра Истина - будет полностью совпадать с наименованием (за исключением "хвостовых" пробелов в наименовании).
    Значение по умолчанию: Ложь<Родитель> (необязательный)

    Тип: СправочникСсылка.
    Родитель, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.<Владелец> (необязательный)

    Тип: СправочникСсылка.
    Владелец, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.Возвращаемое значение:

    Тип: СправочникСсылка.; Неопределено.
    Ссылка на найденный элемент справочника.
    Если не существует ни одного элемента с требуемым наименованием, то будет возвращена пустая ссылка.
    Если для справочника наименование не задано (длина = 0), то будет возвращено Неопределено.Описание:

    Осуществляет поиск элемента по его наименованию.
    Доступность:

    Сервер, толстый клиент, внешнее соединение.Примечание:

    Если существует несколько элементов с указанным наименованием, то будет найден только один из них.Пример:

    СтрокаНаименования = "USD";
    Валюты = Справочники.Валюты;
    НайденнаяСсылка = Валюты.НайтиПоНаименованию(СтрокаНаименования);
    Если
    НайденнаяСсылка = Валюты.ПустаяСсылка() Тогда
    Сообщить("Валюты """ + СтрокаНаименования + """ еще нет");
    КонецЕсли
    ;


Закрытая тема
Страница 1 из 16 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 ... Следующая ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Похожие темы

  1. Ответов: 10
    Последнее сообщение: 08.01.2011, 00:09
  2. Справочники
    от maverick в разделе 7.7
    Ответов: 2
    Последнее сообщение: 05.11.2010, 04:37

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения


Навигация по сайту:
, 1c, 1с 8.2, 1с 8.3, Скачать 1с, 1с бухгалтерия, 1с предприятие, Программа 1с,
1с торговля, 1с управление, 1с зарплата, Обновление 1с, Миста, Программирование 1с,

Положение об ответственности
Связь с администрацией erpsolution.ru@yandex.ru