Для удобного просмотра сайта рекомендуется использовать Google Chrome.


Закрытая тема
Страница 1 из 4 1 2 3 4 Следующая ПоследняяПоследняя
Показано с 1 по 10 из 36

Тема: Оформление Оформление

  1. #1
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию Оформление Оформление

    Цвет (Color)

    Цвет (Color)
    Свойства:

    Вид (Type)
    Зеленый (G)
    Красный (R)
    Синий (B)
    Конструкторы:

    Конструктор по умолчанию
    На основе цветовых составляющих
    Описание:

    Предназначен для определения и хранения значение цвета. Цвет может определяться абсолютным значением (сочетанием красного, синего и зеленого цветов), браться из элементов стиля, из палитры Windows, или использоваться один из web-цветов.
    Может присваиваться в качестве значения атрибутов других объектов, параметров методов, процедур или функций, имеющих тип Цвет.
    Доступность:

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
    Сериализуется. Данный объект может быть сериализован в/из XML. Может использоваться в реквизитах управляемой формы. Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту, определяется в пространстве имен {http://v8.1c.ru/8.1/data/ui}. Имя типа XDTO: ColorПример:

    ЦветВажнойКнопки = Новый Цвет(255, 0, 0); // красный
    ЦветОбычнойКнопки = ЦветаСтиля.ЦветФонаКнопки;

    // Для обычной формы
    Если ОстатокТовара <= Товар.Остаток Тогда
    ЭлементыФормы.КнопкаЗаказать.ЦветФонаКнопки = ЦветВажнойКнопки;
    Иначе
    ЭлементыФормы.КнопкаЗаказать.ЦветФонаКнопки = ЦветОбычнойКнопки;
    КонецЕсли
    ;

    // Для управляемой формы
    Если ОстатокТовара <= Товар.Остаток Тогда
    Элементы.КнопкаЗаказать.ЦветФона = ЦветВажнойКнопки;
    Иначе
    Элементы.КнопкаЗаказать.ЦветФона = ЦветОбычнойКнопки;
    КонецЕсли
    ;


  2. #2
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Свойства:
    Цвет.Вид (Color.Type)


    Цвет (Color)
    Вид (Type)
    Использование:

    Только чтение.Описание:

    Тип: ВидЦвета.
    Содержит вид цвета.
    Доступность:

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

  3. #3
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Цвет.Зеленый (Color.G)

    Цвет (Color)
    Зеленый (G)
    Использование:

    Только чтение.Описание:

    Тип: Число.
    Содержит зеленую составляющую цвета.
    Доступность:

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.Примечание:

    Если цвет задан не абсолютным, то содержит -1.

  4. #4
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Цвет.Красный (Color.R)

    Цвет (Color)
    Красный (R)
    Использование:

    Только чтение.Описание:

    Тип: Число.
    Содержит красную составляющую цвета.
    Доступность:

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.Примечание:

    Если цвет задан не абсолютным, то содержит -1.

  5. #5
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Цвет.Синий (Color.B)

    Цвет (Color)
    Синий (B)
    Использование:

    Только чтение.Описание:

    Тип: Число.
    Содержит синюю составляющую цвета.
    Доступность:

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.Примечание:

    Если цвет задан не абсолютным, то содержит -1.

  6. #6
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Конструкторы:
    Цвет.Конструктор по умолчанию (Color.Default constructor)


    Цвет (Color)
    Конструктор по умолчанию
    Синтаксис:

    Новый Цвет()Описание:

    Создает значение цвета, которое будет использоваться как значение по умолчанию (цвет "Авто").Пример:

    Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Если
    Элемент.ТекущаяСтрока=Неопределено Тогда
    Возврат;
    КонецЕсли
    ;

    Для
    Каждого Офр Из ОформленияСтрок Цикл
    Если Офр.ДанныеСтроки.Важно Тогда
    Офр.ЦветФона = Новый Цвет(197, 255, 185);
    Иначе
    Офр.ЦветФона = Новый Цвет();
    КонецЕсли
    ;
    КонецЦикла
    ;
    КонецПроцедуры


  7. #7
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Цвет.На основе цветовых составляющих (Color.Based on constituent colors)

    Цвет (Color)
    На основе цветовых составляющих
    Синтаксис:

    Новый Цвет(<Красный>, <Зеленый>, <Синий>)Параметры:

    <Красный> (обязательный)

    Тип: Число.
    Значение красной составляющей цвета.<Зеленый> (обязательный)

    Тип: Число.
    Значение зеленой составляющей цвета.<Синий> (обязательный)

    Тип: Число.
    Значение синей составляющей цвета.Описание:

    Формирует абсолютный цвет из трех цветовых составляющих.Пример:

    Для Индекс=1 По Элемент.ШиринаТаблицы Цикл
    Элемент.Область(1,Индекс).ЦветФона=Новый Цвет(255,255,255);
    КонецЦикла
    ;

    КрасныйЦвет = Новый Цвет (255,0,0);
    ЧерныйЦвет = Новый Цвет(0,0,0);


  8. #8
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    ДиалогВыбораЦвета (ColorChooseDialog)

    ДиалогВыбораЦвета (ColorChooseDialog)
    Свойства:

    Цвет (Color)
    Методы:

    Выбрать (Choose)
    Конструкторы:

    По умолчанию
    Описание:

    Предназначен для работы с диалогом специального вида для выбора цвета.
    Доступность:

    Тонкий клиент, толстый клиент, внешнее соединение.

  9. #9
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Свойства:
    ДиалогВыбораЦвета.Цвет (ColorChooseDialog.Color)


    ДиалогВыбораЦвета (ColorChooseDialog)
    Цвет (Color)
    Использование:

    Только чтение.Описание:

    Тип: Цвет.
    Содержит цвет, устанавливаемый при открытии диалога.
    После выбора содержит выбранный цвет.
    Доступность:

    Тонкий клиент, толстый клиент, внешнее соединение.

  10. #10
    Senior Member
    Регистрация
    03.02.2012
    Сообщений
    12,724
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а)
    в 0 сообщениях

    По умолчанию

    Методы:
    ДиалогВыбораЦвета.Выбрать (ColorChooseDialog.Choose)


    ДиалогВыбораЦвета (ColorChooseDialog)
    Выбрать (Choose)
    Синтаксис:

    Выбрать()Возвращаемое значение:

    Тип: Булево.
    Истина - цвет выбран; Ложь - в противном случае.Описание:

    Открывает диалог выбора цвета.
    Доступность:

    Тонкий клиент, толстый клиент, внешнее соединение.

Закрытая тема
Страница 1 из 4 1 2 3 4 Следующая ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения


Навигация по сайту:
, 1c, 1с 8.2, 1с 8.3, Скачать 1с, 1с бухгалтерия, 1с предприятие, Программа 1с,
1с торговля, 1с управление, 1с зарплата, Обновление 1с, Миста, Программирование 1с,

Положение об ответственности
Связь с администрацией erpsolution.ru@yandex.ru